@Geezer17

Как найти различия в двух столбцах Google Sheets и вывести их?

Есть два столбца с текстовыми списками. Нужно найти в первом столбце значения, которые не повторяются во втором, и параллельно найти значения из второго, которые не повторяются в первом. То есть найти различия в списках. Затем нужно вывести результат в отдельный диапазон ячеек - найденные уникальные значения из первого списка в один столбец, а из второго - во второй:
602f427dba7cf103493658.jpeg
Пробовал сделать всё при помощи условного форматирования с формулой
=СЧЁТЕСЛИ($A:$B;A1)<2
с последующей фильтрацией списка по цвету заливки, но на это уходит много ручной работы. Есть ли способ реализовать это как-то по-другому при помощи формулы фильтра или чего-то подобного?
Заранее благодарю!
  • Вопрос задан
  • 70 просмотров
Решения вопроса 1
idShura
@idShura
602fbac69dfcc919430859.png

Формула в ячейке D =FILTER(A1:A11;ISNA(MATCH(A1:A11;B1:B12;0)))
Формула в ячейке E =FILTER(B1:B12;ISNA(MATCH(B1:B12;A1:A11;0)))

Ссылка на пример
Ответ написан
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы