@ZaharLesniak

Установил Gulp локально и пишет «unsupported gulp version». Что делать?

Установил Gulp глобально. Дальше установил локально в VSCode, проверяю его работоспособность
(через команду gulp в терминале) и и выбивает "unsupported gulp version". Можете пожалуйста помочь?
  • Вопрос задан
  • 51 просмотр
Пригласить эксперта
Ответы на вопрос 1
iDmitriyWinX
@iDmitriyWinX
Разверните мне сервер на NGNX, пожалуйста
Ошибка №1: устанавливать Gulp глобально.
Решение: Глобально устанавливают Gulp-CLI

Далее: Что значит локально в VSCode? Плагин что-ли?

Заходите в папку проекта, пишите в терминале npm init, потом npm i gulp --save-dev

Отлично, Gulp установлен в проект и готов к использованию.

Пишите свой gulpfile.js В КОРНЕ ВАШЕГО ПРИЛОЖЕНИЯ (без него ничего не будет).

Теперь заходите в терминал, пишите gulp (если есть таск "default") и всё, он начинает работу. Если у вас вместо таска default, допустим, какое-то другое имя, то пишем в консоли то же самое, только в конец добавляем имя таска gulp имя_таска
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы