@zimbura

Как правильно использовать IF с оператором OR на массиве?

Здравствуйте
Есть одна таблица в которой номера телефонов, к ним нужно подставить имена.
На другом листе "контакты" есть контакты, у каждого контакта 2 столбца с телефонами. Один из телефонов заполнен либо заполнены 2
подскажите как правильно использовать оператор OR (или) в формуле
=ЕСЛИ(ИЛИ($B2='контакты'!$C$2:C;$B2='контакты'!$D$2:$D);"нет таких";'контакты'!$B$2:$B)

В столбце В на текущем листе телефон в формате 71111111111
В столбце C и D на листе "контакты" телефон в формате 71111111111
в столбце B на листе "контакты" имя контакта
Если не сложно как это все обернуть в ARRAYFORMULA
пример таблицы здесь

Реально 2 день ищу решение
Заранее спасибо
  • Вопрос задан
  • 89 просмотров
Решения вопроса 1
PolarBearGG
@PolarBearGG
I know that I know nothing
=arrayformula( if(or('контакты'!$C$2:C=$B2;'контакты'!$D$2:$D=$B2);"нет таких";'контакты'!$B$2:$B))
Ответ написан
Пригласить эксперта
Ответы на вопрос 1
ForestAndGarden
@ForestAndGarden
Без ARRAYFORMULA!

Левый ВПР, взятый с planetaexcel.ru у Николая Павлова:

Для ячейки C2:
=IF(ISERROR(INDEX('контакты'!B$2:B;
(MATCH(B2;'контакты'!C$2:C;0))));IFERROR(INDEX('контакты'!B$2:B;
(MATCH(B2;'контакты'!D$2:D;0)));"нет таких");INDEX('контакты'!B$2:B;
(MATCH(B2;'контакты'!C$2:C;0))))
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы