Как изменить используемую версию php?

Пытаюсь установить phpBB, пишет You are running an unsupported PHP version. Please upgrade to PHP 7.1.3 or higher before trying to install or update to phpBB 3.3
Я обновил php, пишу php -v, ответ
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.1.0, Copyright (c) 1998-2018 Zend Technologies
Но форум все равно не ставиться и пишет, что нужно обновить версию. Как быть?
  • Вопрос задан
  • 204 просмотра
Решения вопроса 1
debian_Lenovo-B50-30
@debian_Lenovo-B50-30
sudo apt remove php*
sudo apt purge php*
sudo apt autoremove
sudo apt install php7.4 php7.4-{xdebug,mysql,mbstring}
sudo systemctl restart apache2
Ответ написан
Пригласить эксперта
Ответы на вопрос 1
Добавление репозитария PHP для установки самой последней версии:

cd /etc/apt/sources.list.d; echo "deb http://ppa.launchpad.net/ondrej/php/ubuntu $(lsb_release -cs) main" | sudo tee php.list > /dev/null; sudo apt-key adv --recv-keys --keyserver hkps://keyserver.ubuntu.com:443 4F4EA0AAE5267A6C; sleep 10; sudo apt update; cd


И тогда уже 7.4 в имя php можно не прописывать.
Автоматом подтянет самые последние версии пакетов.
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы
27 окт. 2020, в 22:44
3000 руб./за проект
27 окт. 2020, в 22:07
50000 руб./за проект
27 окт. 2020, в 21:27
20000 руб./за проект