@ekaterina3785

Как прописать в формуле массив данных?

Здравствуйте!
Нужно составить расписание занятости сотрудников (пофамильно). Ячейка=лицо, которое в данный час занимает комнату. Сотрудников 42, соответственно на пересечении комната - временной промежуток другой таблицы, общей, у меня 45 ячеек (взяла с запасом, вдруг новенькие будут). Использую функцию ЕСЛИ. ЕСЛИ "Фамилия", значит во второй таблицы в индивидуальной ячейке будет слово ЗАНЯТ. Если нет - просто прочерк. Вводить все 45 значений долго, решила воспользоваться массивом. Пишу формулу : =ЕСЛИ(B3:D17="Алексеев";"ЗАНЯТ";"-"). Высвечивается "Не удалось найти значение массива". Пробовала с именованным списком - та же фигня! Что я делаю не так?
  • Вопрос задан
  • 46 просмотров
Решения вопроса 1
dollar
@dollar
Чтобы формула работала с массивами, после ввода нажмите не Enter, а Ctrl+Shift+Enter.

Но только если в параметрах формулы IF будет массив, то и результат будет массивом. Точнее, результат будет иметь те же размеры, что и параметр. У вас B3:D17 имеет размеры 3 на 15, значит область такого же размера заполнится значениями "ЗАНЯТ" и "-". При этом формула будет только в одной ячейке.
Ответ написан
Пригласить эксперта
Ответы на вопрос 1
@ekaterina3785 Автор вопроса
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы