@architawr
"Ok, Google" и все твои проблемы решены

В чем заключается проблема с NPM?

Доброго времени суток.
При попытке установить зависимости через npm i, появляется такая ошибка
5f43acc8ec3fe259188606.png
package.json

{
  "name": "starfish24-analytics",
  "version": "0.1.0",
  "private": true,
  "scripts": {
    "serve": "vue-cli-service serve",
    "build": "vue-cli-service build",
    "test:unit": "vue-cli-service test:unit",
    "lint": "vue-cli-service lint",
    "i18n:report": "vue-cli-service i18n:report --src './src/**/*.?(js|vue)' --locales './src/locales/**/*.json'"
  },
  "dependencies": {
    "apexcharts": "^3.20.0",
    "axios": "^0.19.2",
    "axios-auth-refresh": "^2.2.8",
    "babel-polyfill": "^6.26.0",
    "core-js": "^3.3.2",
    "d3": "^5.14.2",
    "d3-sankey": "^0.12.3",
    "date-fns": "^2.8.1",
    "js-base64": "^3.4.4",
    "qs": "^6.9.1",
    "register-service-worker": "^1.6.2",
    "sweet-modal-vue": "^2.0.0",
    "topojson-client": "^3.1.0",
    "vue": "^2.6.10",
    "vue-apexcharts": "^1.6.0",
    "vue-i18n": "^8.0.0",
    "vue-i18n-filter": "^0.1.6",
    "vue-router": "^3.1.3",
    "vue-the-mask": "^0.11.1",
    "vue2-timepicker": "^1.0.5",
    "vuetify": "^2.1.0",
    "vuex": "^3.0.1",
    "vuex-cache": "^3.1.0"
  },
  "devDependencies": {
    "@babel/preset-env": "^7.10.4",
    "@kazupon/vue-i18n-loader": "^0.3.0",
    "@vue/cli-plugin-babel": "^4.0.0",
    "@vue/cli-plugin-eslint": "^4.0.0",
    "@vue/cli-plugin-pwa": "^4.0.5",
    "@vue/cli-plugin-router": "^4.0.0",
    "@vue/cli-plugin-unit-jest": "^4.0.0",
    "@vue/cli-plugin-vuex": "^4.0.0",
    "@vue/cli-service": "^4.0.0",
    "@vue/eslint-config-prettier": "^5.0.0",
    "@vue/test-utils": "1.0.0-beta.29",
    "babel-eslint": "^10.0.3",
    "eslint": "^5.16.0",
    "eslint-plugin-prettier": "^3.1.1",
    "eslint-plugin-vue": "^5.0.0",
    "node-sass": "^4.12.0",
    "prettier": "^1.18.2",
    "sass": "^1.19.0",
    "sass-loader": "^8.0.0",
    "vue-cli-plugin-i18n": "^0.6.0",
    "vue-cli-plugin-pug": "^1.0.7",
    "vue-cli-plugin-vuetify": "^2.0.2",
    "vue-cli-plugin-webpack-bundle-analyzer": "^2.0.0",
    "vue-template-compiler": "^2.6.10",
    "vuetify-loader": "^1.3.0"
  }
}


При необходимости могу скинуть логи npm-a

ПС: странно, что при установке зависимостей через yarn все работает корректно
  • Вопрос задан
  • 27 просмотров
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы
28 сент. 2020, в 00:10
15000 руб./за проект
27 сент. 2020, в 21:54
15000 руб./за проект