@mega-sinyak

Что за варнинги?

Разрабы PhpStorm в последних релизах отказались от автоматической минификации посредством YUI Compressor и предложили использовать другие пакеты, ставлю:
C:\Users\Lenovo>npm i -g csso-cli uglify-js
C:\Users\Lenovo\AppData\Roaming\npm\csso -> C:\Users\Lenovo\AppData\Roaming\npm\node_modules\csso-cli\bin\csso
C:\Users\Lenovo\AppData\Roaming\npm\uglifyjs -> C:\Users\Lenovo\AppData\Roaming\npm\node_modules\uglify-js\bin\uglifyjs
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@~2.1.2 (node_modules\csso-cli\node_modules\chokidar\node_modules\fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.3: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"})

+ uglify-js@3.10.1
+ csso-cli@3.0.0
added 28 packages from 58 contributors in 7.615s

C:\Users\Lenovo>

Что за два варнинга?
Исправлять нужно что-то?
  • Вопрос задан
  • 105 просмотров
Решения вопроса 1
Aetae
@Aetae
Тлен
Нет. Ничего делать не надо. Это опциональная зависимость от fsevents(наблюдатель за файлами для линуха), тебе она, соответственно, не нужна.
Ответ написан
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы