ioangrozniy
@ioangrozniy

Почему отрубается asterisk?

Доброго времени суток. Ситуация в следующем.
Решил всё перетащить в бд. Установил mysql.
Настроил ODBC в астериске. В базу перенёс пользователей и диалплан.
Перезагружаю астер, всё работает. Звоню - звонок проходит.
Сбрасываю, перезваниваю - глухо.
К тому же в придачу вылетает консоль астериска.

== Using SIP RTP CoS mark 5
== Using SIP RTP CoS mark 5
asterisk*CLI>
Disconnected from Asterisk server
Asterisk cleanly ending (0).
Executing last minute cleanups

возвращаю все планы на extensions.conf и всё работает как часы.
Помогите пожалуйста, куда копать?

Ни кто разве не сталкивался с таким?
Из лога:
[May 5 11:33:31] DEBUG[2128][C-00000001] res_config_odbc.c: Skip: 0; SQL: SELECT * FROM extensions WHERE exten = ? AND priority = ? AND context = ?
[May 5 11:33:31] DEBUG[2128][C-00000001] res_config_odbc.c: Parameter 1 ('exten') = '1002'
[May 5 11:33:31] DEBUG[2128][C-00000001] res_config_odbc.c: Parameter 2 ('priority') = '1'
[May 5 11:33:31] DEBUG[2128][C-00000001] res_config_odbc.c: Parameter 3 ('context') = 'outcalling'
[May 5 11:33:31] DEBUG[2128][C-00000001] res_odbc.c: Releasing ODBC handle 0x34b3140 into pool
[May 5 11:33:31] DEBUG[2128][C-00000001] res_odbc.c: Reusing ODBC handle 0x34b3140 from class 'asterisk'
[May 5 11:33:31] DEBUG[2128][C-00000001] res_config_odbc.c: Skip: 0; SQL: SELECT * FROM extensions WHERE exten LIKE ? AND priority = ? AND context = ? ORDER BY exten
[May 5 11:33:31] DEBUG[2128][C-00000001] res_config_odbc.c: Parameter 1 ('exten LIKE') = '\_%'
[May 5 11:33:31] DEBUG[2128][C-00000001] res_config_odbc.c: Parameter 2 ('priority') = '1'
[May 5 11:33:31] DEBUG[2128][C-00000001] res_config_odbc.c: Parameter 3 ('context') = 'outcalling'
[May 5 11:33:31] DEBUG[2128][C-00000001] res_odbc.c: Releasing ODBC handle 0x34b3140 into pool
[May 5 11:33:36] Asterisk 17.3.0 built by root @ centos7asterisk on a x86_64 running Linux on 2020-04-30 13:06:31 UTC

То есть получается, что астер падает после простого запроса в базу? Как так? Может версия автера 17.3.0 сырая? Может, что то дополнительно настраивать надо? Подскажите пожалуйста.
  • Вопрос задан
  • 149 просмотров
Пригласить эксперта
Ответы на вопрос 1
ioangrozniy
@ioangrozniy Автор вопроса
После долгих мытарств поставил Астер 16.10.0
Всё заработало. Так что как я понял - это косяки версии 17.3.0
Очень жаль.
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы