chazovs
@chazovs
Компания Вебпрактик

Как поставить infyom на Laravel 6?

Пытаюсь поставить на Laravel 6 CRUD генератор INFYOM.
Сам генератор вроде даже работает. Но когда я пытаюсь зайти на страницу модели в адмике, то выясняется, что
Class 'Yajra\DataTables\Services\DataTable' not found


Я понимаю, почему нет этого класса. Потому что для Laravel 6 INFYOM устанавливает 9 версию Yajra, в которой класс DataTable был подло заменен на Yajra\DataTables\DataTablesServiceProvider
Если я пытаюсь через композер поставить 7, например, версию Yajra, то меня шлют, со словами Conclusion: remove laravel/framework v6.16.0
Ну типа установи себе другую ларку - там и поговорим.
Естественно, простая замена на Yajra\DataTables\DataTablesServiceProvider результата не дает. Тогда ругательство выглядит примерно так:
Unresolvable dependency resolving [Parameter #0 [ <required> $app ]] in class Illuminate\Support\ServiceProvider


Вообщем тупик.
  • Вопрос задан
  • 102 просмотра
Пригласить эксперта
Ответы на вопрос 2
@vism
Печальноб 2 дня...
https://github.com/InfyOmLabs/laravel-generator/is...

вобще этот класс только в стабах используется, потому надо ставить последние версии, прочитать документацию и если надо подредактировать стабы.
Ответ написан
chazovs
@chazovs Автор вопроса
Компания Вебпрактик
Вообщем оказалось, что проблема решается с помощью установки пакета "yajra/laravel-datatables-buttons"
прописывании Yajra\DataTables\ButtonsServiceProvider::class в провайдерах
и потом php artisan vendor:publish --tag=datatables-buttons --force
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы
01 апр. 2020, в 11:42
3000 руб./за проект
01 апр. 2020, в 10:05
5000 руб./за проект
01 апр. 2020, в 09:55
1000 руб./за проект