@strelkovandreyvalerievich

Какую нужно использовать библиотеку в PHP 7.2 (Win) для работы с Oracle 11g?

Добрый день, подскажите пожалуйста, какую нужно использовать библиотеку, и где её скачать для работы в PHP7.2 (windows, x64) c СУБД Oracle 11g?
Из коробки в php 7.2 идёт только библиотека для 12c, 11g уже отсутствует.
  • Вопрос задан
  • 82 просмотра
Пригласить эксперта
Ответы на вопрос 1
JhaoDa
@JhaoDa
LaravelRUS Team
Вы проверили, что оно не коннектится с 11g, или увидели php_oci8_12c.dll и решили, что работать не будет?

Документация гласит, что
DLL файл php_oci8_12c DLL из PECL требует клиентские библиотеки версии Oracle 12сR1

и

Если OCI8 использует клиентские библиотеки 12с, то база данных может иметь версии 10g, 11g или 12c.
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы
Sportmaster Lab Москва
До 250 000 ₽
Сбербанк Москва
от 190 000 до 230 000 ₽
Сбербанк Москва
от 200 000 до 260 000 ₽
12 июл. 2020, в 23:05
25000 руб./за проект
12 июл. 2020, в 22:52
750 руб./за проект