@Lyuba2018

Как обновить jQuery?

Подскажите у меня на сайте стоит jquery 1.4 я хочу ее обновить до jquery 3.1 будет ли после этого корректно работать сайт ? Или как проверить какую версию jquery поддерживает скрипт ?
  • Вопрос задан
  • 1353 просмотра
Пригласить эксперта
Ответы на вопрос 3
Rikcon
@Rikcon
c 1.4 до 3.1 крайне вряд-ли, у вас там может быть jquery плагины тоже старые, а они написаны для 1.x

С вашим кодом вам поможет Jquery Migrate
Но не спешите брать его последнюю версию, у вас долгий путь будет, миграция с 1.x до 2.x и только потом с 2.x до 3.x

NOTE: To upgrade to jQuery 3.0, you first need version 1.12.x or 2.2.x. If you're using an older version, first upgrade to one of these versions using jQuery Migrate 1.x, to resolve any compatibility issues. For more information about the changes made in jQuery 3.0, see the upgrade guide and blog post.
Ответ написан
webinar
@webinar Куратор тега jQuery
Учим yii: https://youtu.be/-WRMlGHLgRg
будет ли после этого корректно работать сайт ?

Зависит от скриптов, которые используют jquery. Что мешает проверить и пообновлять те скрипты которые устарели?
Ответ написан
Sanovskiy
@Sanovskiy
Веб-разработчик с 2005 года
Попробуйте подключать jQuery через Google Hosted Libraries
Очень просто переключить с одной версии на другую.
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы