leshikgo
@leshikgo

Как работать с composer?

Здравствуйте. Помогите разобраться с composer. Суть такова, ставил пакеты, всё норм, ничего не конфликтовало. Сегодня нужно было поставить очередной пакет и для него нужны такие зависимости:
"illuminate/http": "~5.4",
"illuminate/support": "~5.4"

Я их вписал в composer.json и при composer update он ругается(конфликт) на то что для другой зависимости "illuminate/http": нужна версия меньше 5.4. Как тут быть ? Ставлю laravel/socialite v3.0.0
То есть как решить вопрос с конфликтом версий зависимостей.
  • Вопрос задан
  • 438 просмотров
Решения вопроса 1
AmdY
@AmdY
PHP и прочие вебштучки
Зачем вы их вписывали в свой composer.json. Смысл как раз в том, что зависимости резолвятся рекурсивно и тебе нужно указывать лишь твой пакет и его версию, а дальше уже тебе рассчитают все нужные зависимости и нужные версии этих зависимостей.

Но в любом случае, раз у вас проблема в другом пакете которому нужна версия меньше 5.4, то имеет смысл написать о нём и его версии, возможно указать более свежую версию, которая совместима с 5.4

>>laravel/socialite v3.0.0
этот пакет протух, актуальная версия 3.0.2, будьте аккуратны в прописывании версий, разберитесь с марковками, тильдами и вайлкардами, чтобы потом не страдать. К сожалению в многих пакетах авторы не заморочились этим и плодят конфликты на ровном месте. В таком случае проще форкнуть и прописать поправить версии, послать автору пулл реквест.
Ответ написан
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы