Kuhnya
@Kuhnya
Просто щелкунчик. Просто - на просто...

Почему при установке npm сыплет ошибками?

Пытаюсь установить node.js, чтобы поработать со swagger editor, но при установке npm вываливается море ошибок:
npm error code ERESOLVE
npm error ERESOLVE could not resolve
npm error
npm error While resolving: react-ace@4.4.0
npm error Found: react@18.3.1
npm error node_modules/react
npm error   react@">=17 <19" from the root project
npm error   peer react@">=18" from @cfaester/enzyme-adapter-react-18@0.8.0
npm error   node_modules/@cfaester/enzyme-adapter-react-18
npm error     dev @cfaester/enzyme-adapter-react-18@"^0.8.0" from the root project
npm error   14 more (boron, react-copy-to-clipboard, react-debounce-input, ...)
npm error
npm error Could not resolve dependency:
npm error peer react@"^0.13.0 || ^0.14.0 || ^15.0.1" from react-ace@4.4.0
npm error node_modules/react-ace
npm error   react-ace@"^4.1.6" from the root project
npm error
npm error Conflicting peer dependency: react@15.7.0
npm error node_modules/react
npm error   peer react@"^0.13.0 || ^0.14.0 || ^15.0.1" from react-ace@4.4.0
npm error   node_modules/react-ace
npm error     react-ace@"^4.1.6" from the root project
npm error
npm error Fix the upstream dependency conflict, or retry
npm error this command with --force or --legacy-peer-deps
npm error to accept an incorrect (and potentially broken) dependency resolution.
npm error
npm error
npm error For a full report see:
npm error C:\Users\user\AppData\Local\npm-cache\_logs\2024-06-21T09_16_11_293Z-eresolve-report.txt
npm error A complete log of this run can be found in: C:\Users\user\AppData\Local\npm-cache\_logs\2024-06-21T09_16_11_293Z-debug-0.log


куда лезть? я новичок в этом, ставлю, чтобы разобраться.

upd#1. всё делаю по инструкции отсюда:
https://www.linkedin.com/pulse/how-set-up-swagger-...

на шаге npm install лезет вот это
  • Вопрос задан
  • 117 просмотров
Решения вопроса 1
black1277
@black1277
Вольный стрелок
Вы всё правильно делали. Это у них в пакете конфликты зависимостей неразруленные. Чтобы все установилось используйте команду:
npm i --legacy-peer-deps
это установит пакеты невзирая на предупреждения и все будет работать (я проверил). Надеюсь версия Node у вас не древняя, я проверял на 20-й
Ответ написан
Пригласить эксперта
Ответы на вопрос 1
@drugbanIT
надо зайти в папку пользователи (users) далее в папку user потом в appdata потом в roaming и там создать папку (npm)
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы