@gleiv

Почему не устанавливаются зависимости npm?

Следуя этому гайду по БЭМ клонировал репозиторий
git clone https://github.com/bem/project-stub.git --depth 1 start-project

Ошибок не было. После npm install возникает такая ошибка:
npm WARN EBADENGINE Unsupported engine {
npm WARN EBADENGINE   package: 'puml-link@0.0.1',
npm WARN EBADENGINE   required: { node: '0.10' },
npm WARN EBADENGINE   current: { node: 'v16.17.1', npm: '8.19.2' }
npm WARN EBADENGINE }
  • Вопрос задан
  • 80 просмотров
Пригласить эксперта
Ответы на вопрос 1
easimonenko
@easimonenko
Программист, блогер, преподаватель.
Пакет требует Node.js версии 0.10, а установлен 16.17.1. В репозитории bem последний коммит сделан в 2018 году. По-видимому код не поддерживается и устарел. Если сильно нужно, то можно поработать с напильником и попытаться обновить зависимости до актуальных, предварительно сделав форк проекта...
Ответ написан
Комментировать
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы
Рулю Екатеринбург
от 110 000 до 120 000 ₽
Gradient Москва
от 180 000 ₽
от 150 000 до 200 000 ₽
06 дек. 2022, в 20:37
10000 руб./за проект
06 дек. 2022, в 20:31
20000 руб./за проект
06 дек. 2022, в 20:26
2500 руб./за проект