@qwelp

Webpack — TypeError: Invalid value used in weak set Как поправить?

При попытки собрать проект, выскакивает ошибка, подскажите как поправить

$ webpack --env production --progress
P:\OpenServer\domains\eurodisks\frontend\node_modules\webpack-cli\bin\cli.js:422
                                throw err;
                                ^

TypeError: Invalid value used in weak set
    at WeakSet.add (<anonymous>)
    at MiniCssExtractPlugin.apply (P:\OpenServer\domains\eurodisks\frontend\node_modules\mini-css-extract-plugin\dist\index.js:640:18)
    at webpack (P:\OpenServer\domains\eurodisks\frontend\node_modules\webpack\lib\webpack.js:51:13)
    at processOptions (P:\OpenServer\domains\eurodisks\frontend\node_modules\webpack-cli\bin\cli.js:413:16)
    at P:\OpenServer\domains\eurodisks\frontend\node_modules\webpack-cli\bin\cli.js:503:3
    at Object.parse (P:\OpenServer\domains\eurodisks\frontend\node_modules\yargs\yargs.js:567:18)
    at P:\OpenServer\domains\eurodisks\frontend\node_modules\webpack-cli\bin\cli.js:206:8
    at Object.<anonymous> (P:\OpenServer\domains\eurodisks\frontend\node_modules\webpack-cli\bin\cli.js:505:3)
    at Module._compile (node:internal/modules/cjs/loader:1105:14)
    at Object.Module._extensions..js (node:internal/modules/cjs/loader:1159:10)
    at Module.load (node:internal/modules/cjs/loader:981:32)
    at Function.Module._load (node:internal/modules/cjs/loader:822:12)
    at Module.require (node:internal/modules/cjs/loader:1005:19)
    at require (node:internal/modules/cjs/helpers:102:18)
    at Object.<anonymous> (P:\OpenServer\domains\eurodisks\frontend\node_modules\webpack\bin\webpack.js:156:2)
    at Module._compile (node:internal/modules/cjs/loader:1105:14)
    at Object.Module._extensions..js (node:internal/modules/cjs/loader:1159:10)
    at Module.load (node:internal/modules/cjs/loader:981:32)
    at Function.Module._load (node:internal/modules/cjs/loader:822:12)
    at Function.executeUserEntryPoint [as runMain] (node:internal/modules/run_main:77:12)
    at node:internal/main/run_main_module:17:47
error Command failed with exit code 1.
info Visit https://yarnpkg.com/en/docs/cli/run for documentation about this command.
  • Вопрос задан
  • 51 просмотр
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы
10 авг. 2022, в 22:56
3000 руб./за проект
10 авг. 2022, в 21:54
10000 руб./за проект
10 авг. 2022, в 21:48
3000 руб./за проект