@denis-chenykh

Почему npm не хочет устанавливать пакеты?

Подскажите, пожалуйста, из-за чего npm не хочет устанавливаться

Изначально был проект на react + laravel, который я просто скопировал, назвал по другому корневую папку и все
При npm run devepment в консоли нет ошибок, но визуально на странице ничего не обновляется
Решил удалить node_modules и переустановить все, почистил кэш на laravel

При npm i вылезают вот такие ошибки
npm WARN EBADENGINE Unsupported engine {
npm WARN EBADENGINE package: 'report@0.1.1',
npm WARN EBADENGINE required: { node: '~0.6.18' },
npm WARN EBADENGINE current: { node: 'v16.8.0', npm: '8.1.0' }
npm WARN EBADENGINE }

Убирал вручную данный пакет report
Удалял package-lock.json
Но все равно данная ошибка появляется
  • Вопрос задан
  • 2718 просмотров
Решения вопроса 1
@ikutin666
ошибка говорит, что ожидается node 0.6.18, 0.6.19, 0.6.20 ... а установлена 16.8.0
Ответ написан
Комментировать
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы