Shah_Alina
@Shah_Alina
Нумеролог, корректолог жизненных дорог

Можно ли объединить в одну формулу сложение и если больше 9, то сложить эти цифры?

https://docs.google.com/spreadsheets/d/1bKzv84kFGu...

Хочется объединить две формулы. иначе много придется писать формул.
Задача - в ячейке K4 сложить две цифры? и если сумма получается больше 9, т.е. двузначное число, например 13, то сложить 1+3 и в ячейке нужно видеть значение 4.

Делаю так, не получаю нужный результат:
=ЕСЛИ(($N$1+$G$1)<10;K4;(ПСТР(K4;1;1)+ПСТР(K4;2;1)))

Подскажите, пожалуйста, что необходимо исправить в формуле?
  • Вопрос задан
  • 192 просмотра
Решения вопроса 3
idShura
@idShura
=IF($N$1+$G$1>9;1+3)

upd

==IF(($N$1+$G$1)<10;$N$1+$G$1;(MID($N$1+$G$1;1;1)+MID($N$1+$G$1;2;1)))
Ответ написан
ProgrammerForever
@ProgrammerForever Куратор тега Google Sheets
Учитель, автоэлектрик, программист, музыкант
Видимо как-то так:
=если(
	(G1+N1)<10
	;(G1+N1)
	;остат((G1+N1);10)+целое((G1+N1)/10)
)
Ответ написан
oshliaer
@oshliaer Куратор тега Google Sheets
Google Products Expert
Рекурсивный вызов невозможен. Общая формула для двузначных чисел меньше 100 имеет вид

=SUM(
  SPLIT(REGEXREPLACE(
    "" & SUM(SPLIT(REGEXREPLACE(
      "" & B2;"(\d)";"$1;");
      ";"));"(\d)";"$1;"
  );";")
)


6128b746c0001169768622.png
Ответ написан
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы