Alixx
@Alixx

Почему не ставится laravel-websockets?

Здравствуйте. Используется windows 10, xampp, laravel 5.7. Не ставится laravel-websockets. Даже на заново созданный проект 5.7 (пустой проект, создала и сразу запустила composer require laravel-websockets) и на заново созданный проект 5.8 выдаёт ошибку:
# composer require beyondcode/laravel-websockets
Using version ^1.12 for beyondcode/laravel-websockets
./composer.json has been updated
Running composer update beyondcode/laravel-websockets
Loading composer repositories with package information
Updating dependencies
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - beyondcode/laravel-websockets[1.12.0, ..., 1.x-dev] require illuminate/broadcasting ^6.0|^7.0|^8.0 -> found illuminate/broadcasting[v6.0.0, ..., 6.x-dev, v7.0.0, ..., 7.x-dev, v8.0.0, ..., 8.x-dev] but these were not loaded, likely because it conflicts with another require.
    - Root composer.json requires beyondcode/laravel-websockets ^1.12 -> satisfiable by beyondcode/laravel-websockets[1.12.0, 1.x-dev].

Installation failed, reverting ./composer.json and ./composer.lock to their original content.

Подскажите, как решить этот конфликт? Почему даже на новых проектах конфликт?
  • Вопрос задан
  • 66 просмотров
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы