Viji
@Viji
Associate DevOps Engineer

Почему пакет не обновляется до последней версии/debian 10?

Привет всем,

base image - Debian 10.9 пытаюсь обновить все пакеты до последней (
apt-get update --allow-releaseinfo-change  ## Repository 'http://deb.debian.org/debian buster InRelease' changed its 'Version' value from '10.9' to '10.10' - что нормально и понятно

apt-get update and apt-get upgrade -y


- ничего не находит, хотя например для следующего пакета libgnutls30 есть обновления с 3.6.7-4+deb10u6 до 3.6.7-4+deb10u7

https://packages.debian.org/buster/amd64/libgnutls...

приходится делать
apt-get update --allow-releaseinfo-change && apt-get update
apt-get install libgnutls30


почему так?

с уважением,
Вадим
  • Вопрос задан
  • 91 просмотр
Пригласить эксперта
Ответы на вопрос 2
DollyPapper
@DollyPapper
Может у вас в сурс листе прописаны репозитории в которых еще пакеты не выложены? Проверьте.
Ответ написан
Viji
@Viji Автор вопроса
Associate DevOps Engineer
Да нет, у меня debian 10.9 и после apt-get update --allow-releaseinfo-change
ничего в sources.list не меняется, но если устанавливаешь что-новое, то начинает устанавливаться для последней debian 10.10
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы