config dhcp '3g'
option interface '3g'
option ignore 1 # DHCP Off
config zone
option name 'wan'
option network 'wan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'REJECT'
option masq '1'
option mtu_fix '1'
config rule
option src '3g'
option dest_port '22'
option target 'ACCEPT'
option proto 'tcp'
root@OpenWrt:~# dmesg
...
[ 38.970000] option 1-1:1.0: no of_node; not parsing pinctrl DT
[ 38.970000] option 1-1:1.0: GSM modem (1-port) converter detected
[ 38.970000] option1 ttyUSB0: no of_node; not parsing pinctrl DT
[ 38.970000] usb 1-1: GSM modem (1-port) converter now attached to ttyUSB0
[ 38.970000] option 1-1:1.1: no of_node; not parsing pinctrl DT
[ 38.970000] option 1-1:1.1: GSM modem (1-port) converter detected
[ 38.970000] option1 ttyUSB1: no of_node; not parsing pinctrl DT
[ 38.970000] usb 1-1: GSM modem (1-port) converter now attached to ttyUSB1
[ 38.970000] option 1-1:1.2: no of_node; not parsing pinctrl DT
[ 38.970000] option 1-1:1.2: GSM modem (1-port) converter detected
[ 38.970000] option1 ttyUSB2: no of_node; not parsing pinctrl DT
[ 38.970000] usb 1-1: GSM modem (1-port) converter now attached to ttyUSB2
[ 38.970000] option 1-1:1.3: no of_node; not parsing pinctrl DT
[ 38.970000] option 1-1:1.3: GSM modem (1-port) converter detected
[ 38.970000] option1 ttyUSB3: no of_node; not parsing pinctrl DT
[ 38.970000] usb 1-1: GSM modem (1-port) converter now attached to ttyUSB3
[ 38.970000] option 1-1:1.4: no of_node; not parsing pinctrl DT
[ 38.970000] option 1-1:1.4: GSM modem (1-port) converter detected
[ 39.290000] option1 ttyUSB4: no of_node; not parsing pinctrl DT
[ 39.300000] usb 1-1: GSM modem (1-port) converter now attached to ttyUSB4
config interface '3g'
option ifname 'ppp0'
option pincode '1111'
option device '/dev/ttyUSB3'
option apn 'www.kyivstar.net'
option service 'umts'
option proto '3g'
root@OpenWrt:~# cd /dev
root@OpenWrt:/dev# ls
bus mtd3ro network_throughput ttyS2
console mtd4 null ttyS3
cpu_dma_latency mtd4ro ptmx ttyS4
full mtd5 pts ttyS5
kmsg mtd5ro random ttyS6
log mtd6 shm ttyS7
mem mtd6ro tty ttyS8
memory_bandwidth mtdblock0 ttyS0 ttyS9
mtd0 mtdblock1 ttyS1 urandom
mtd0ro mtdblock2 ttyS10 watchdog
mtd1 mtdblock3 ttyS11 watchdog0
mtd1ro mtdblock4 ttyS12 zero
mtd2 mtdblock5 ttyS13
mtd2ro mtdblock6 ttyS14
mtd3 network_latency ttyS15
ping 127.15.2.8
PING 127.15.2.8 (127.15.2.8): 56 data bytes
64 bytes from 127.15.2.8: seq=0 ttl=64 time=0.780 ms
64 bytes from 127.15.2.8: seq=1 ttl=64 time=0.900 ms
64 bytes from 127.15.2.8: seq=2 ttl=64 time=10.660 ms
64 bytes from 127.15.2.8: seq=3 ttl=64 time=0.720 ms
64 bytes from 127.15.2.8: seq=4 ttl=64 time=0.700 ms
64 bytes from 127.15.2.8: seq=5 ttl=64 time=0.700 ms
64 bytes from 127.15.2.8: seq=6 ttl=64 time=0.680 ms
64 bytes from 127.15.2.8: seq=7 ttl=64 time=0.700 ms
64 bytes from 127.15.2.8: seq=8 ttl=64 time=0.720 ms
64 bytes from 127.15.2.8: seq=9 ttl=64 time=0.700 ms
64 bytes from 127.15.2.8: seq=10 ttl=64 time=0.700 ms
64 bytes from 127.15.2.8: seq=11 ttl=64 time=0.760 ms
64 bytes from 127.15.2.8: seq=12 ttl=64 time=0.700 ms
64 bytes from 127.15.2.8: seq=13 ttl=64 time=0.720 ms
64 bytes from 127.15.2.8: seq=14 ttl=64 time=110.880 ms
а вот пинг реального сервера...(
root@OpenWrt:~# ping 185.28.20.100
PING 185.28.20.100 (185.28.20.100): 56 data bytes
ping: sendto: Network unreachable