@Ost123
Программист, эникейщик

Как исправить Module build failed (from ../node_modules/mini-css-extract-plugin/dist/loader.js)?

Делал окружение для js, потом подключил MiniCssExtractPlugin и вышла ошибка : Module build failed (from ../node_modules/mini-css-extract-plugin/dist/loader.js):
ValidationError: Invalid options object. Mini CSS Extract Plugin Loader has been initialized usich the API schema.
- options has an unknown property 'reloadAll'. These properties are valid:
object { publicPath?, emit?, esModule?, layer?, modules? }
at validate (C:\Users\Остап\Desktop\site2\node_modules\schema-utils\dist\validate.js:104:11)
at Object.pitch (C:\Users\Остап\Desktop\site2\node_modules\mini-css-extract-plugin\dist\load @ ./index.js 2:0-27

Вот код:
Webpack config js
const MiniCssExtractPlugin = require('mini-css-extract-plugin')

use: [
              {
                loader: MiniCssExtractPlugin.loader,
                options: {
                  hmr: isDev,
                  reloadAll: true
                }
              }, 
              "css-loader",
              "sass-loader",
            ]
  • Вопрос задан
  • 328 просмотров
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы