@LakeForest

Что за ошибка при запуске Flask для TTS: AttributeError: module 'tensorflow.compat.v2' has no attribute '__internal__'?

Поправил одно, установив tensorflow==2.3.1:
AttributeError: module 'keras.utils.generic_utils' has no attribute 'populate_dict_with_module_objects'

Теперь другое:
AttributeError: module 'tensorflow.compat.v2' has no attribute '__internal__'

File "C:\Users\max\PycharmProjects\pythonProject\venv\lib\site-packages\keras\__init__.py", line 20, in <module>
    from . import initializers
  File "C:\Users\max\PycharmProjects\pythonProject\venv\lib\site-packages\keras\initializers\__init__.py", line 124, in <module>
    populate_deserializable_objects()
  File "C:\Users\max\PycharmProjects\pythonProject\venv\lib\site-packages\keras\initializers\__init__.py", line 49, in populate_deserializable_objects
    LOCAL.GENERATED_WITH_V2 = tf.__internal__.tf2.enabled()
AttributeError: module 'tensorflow.compat.v2' has no attribute '__internal__'
  • Вопрос задан
  • 323 просмотра
Пригласить эксперта
Ответы на вопрос 1
@jisam27275
Мне помогла обычная переустановка пакета tensorflow:
pip3 install tensorflow --upgrade --force-reinstall
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы