@sortfact333

Проблема с модулем DracoEncoderModule. Как решить?

При использовании
new DRACOExporter();
я получаю ошибку
'THREE.DRACOExporter: required the draco_decoder to work.'

Я проверил весь файл и так и не понял как он должен получить DracoEncoderModule.
в DRACOExporter.
Ведь во всем файле нет никакой загрузки этого модуля
export code
Но он все равно работает в примерах three.js на оф.сайте
Почему тогда он не работает у меня?
  • Вопрос задан
  • 14 просмотров
Решения вопроса 1
RAX7
@RAX7
DracoEncoderModule подключается глобально скриптом
<script src="js/libs/draco/draco_encoder.js"></script>

либо WASM версия декодера
<script src="js/libs/draco/draco_wasm_wrapper.js"></script>

https://github.com/mrdoob/three.js/tree/master/exa...
Ответ написан
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы