Lopkop
@Lopkop

Что делать если ошибка при скачивании googleapiclient через pip?

Привет, может кто встречался с такой проблемой:
Когда я пишу "pip install googleapiclient.discovery" python выдаёт ошибку:
"Could not find a version that satisfies the requirement googleapiclient.discovery"
"No matching distribution found for googleapiclient.discovery"?
Когда пишу "pip install googleapiclient" выходит та же ошибка
Это не помогает:
pip install google-api-python-client

Когда я пишу "import googleapiclient.discovery" Пайчарм не отмечает, что это ошибка, но когда я запускаю программу вылетает: "module googleapiclient has no attribute discovery"
Хотя этот модуль имеет атрибут discovery

Пробовал на разных версиях python, в гугле насчёт этого не очень много информации, а если она и есть, то она к сожалению не решает эту проблему
  • Вопрос задан
  • 61 просмотр
Решения вопроса 1
Вот тут https://stackoverflow.com/questions/47428347/googl... советуют делать так
pip3 install --upgrade google-api-python-client
Ответ написан
Пригласить эксперта
Ответы на вопрос 1
@AVKor
Пользоваться надо официальной документацией. И указывать в тексте вопроса, какая версия Пайтона, какая ОС и выхлоп при установке.
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы
08 мар. 2021, в 10:02
75000 руб./за проект
08 мар. 2021, в 10:00
700 руб./за проект
08 мар. 2021, в 08:37
3000 руб./за проект