Почему не работает маркировка пакетов для отправки через другой маршрут на Mikrotik через OpenVPN?

Привет всем!
На микротике настроен ovpn клиент (ovpn-out1)
/ip firewall address-list add address=8.8.8.8 list=through_vpn
/ip firewall mangle add action=mark-routing chain=prerouting dst-address-list=through_vpn in-interface=bridge1 new-routing-mark=through_vpn passthrough=yes
/ip route add distance=1 gateway=ovpn-out1 routing-mark=through_vpn
/ip firewall nat add action=masquerade chain=srcnat out-interface=ovpn-out1

Трассирую с самого микротика 8.8.8.8 - пакеты идут обычным образом.
Если создаю маршрут вручную через ovpn-out1 до адреса 8.8.8.8 - все идет через vpn (то есть gateway там рабочий).
Причем если включить логирование на mangle правиле - в логах ничего нет.
Можете подсказать почему?

В данном случае 8.8.8.8 - для теста.
  • Вопрос задан
  • 63 просмотра
Пригласить эксперта
Ответы на вопрос 1
@nApoBo3
Потому что у вас в mangle in interface указан. Это для forward трафика, а с самого mikrotik у вас output трафик.
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы