@AlphaScript

Почему крашится Qt Quick Application — Empty?

Доброго времени суток. Считаю, что важно уточнить перед самим вопросом, что я использую ОС Ubuntu 20.04.

Установил Qt ( С помощью команды sudo apt-get install qt5-default qtcreator ). И сразу же решил проверить работоспособность, создал проект Qt Quick Application - Empty. И ничего не изменяя, скомпилировал. Запускается проект и работает форма несколько секунд ( Фото ниже ), а потом вылетает со следующими ошибками ( Обычный режим компиляции ):
QML debugging is enabled. Only use this in a safe environment.
The program has unexpectedly finished.
The process was ended forcefully.
.../temp/build-temp-Desktop-Debug/temp crashed.


Скриншот работы программы
5fc63878d244f471064918.png


Компилируя в режиме Debug, та же ситуация, только выдает окно со следующим содержимым:
The inferior stopped because it received a signal from the operating system.
Signal name :  SIGSEGV
Signal meaning : Segmentation fault


Поставил флаг export QT_DEBUG_PLUGINS=1 и запустил программу в консоли и получил следующие ошибки:
Got keys from plugin meta data ("xcb_glx")
QFactoryLoader::QFactoryLoader() checking directory path ".../temp/build-temp-Desktop-Debug/xcbglintegrations" ...
loaded library "/usr/lib/x86_64-linux-gnu/qt5/plugins/xcbglintegrations/libqxcb-glx-integration.so"
QFactoryLoader::QFactoryLoader() checking directory path "/usr/lib/x86_64-linux-gnu/qt5/plugins/accessiblebridge" ...
QFactoryLoader::QFactoryLoader() checking directory path ".../temp/build-temp-Desktop-Debug/accessiblebridge" ...
Segmentation fault (core dumped)


После этого сообщения есть подозрение, что оно не может найти плагин accessiblebridge. Но даже если это так - я не знаю как исправить данную проблему. Есть вероятность, что я плохо искал, но я не нашел какой-то информации по моей проблеме на Убунту.

Также проверял приложение qtcreator с помощью инструмента ldd - все *.sо файлы присутствуют. Билдил с помощью Debug, Profile, Release - результат один и тот же.

Буду очень благодарен любому совету и помощи.
  • Вопрос задан
  • 110 просмотров
Пригласить эксперта
Ответы на вопрос 2
Zifix
@Zifix Куратор тега Qt
Barbatum
Ставьте версию с официального сайта, в дистрибутивах часто криво собирают.
Ответ написан
IGHOR
@IGHOR Куратор тега Qt
Qt/C++ DEV/CTO
Если вы через ldd проверяете зависимости своего бинарника, плагины там не будет видно.
Зависимость плагинов через ldd надо проверять в папке Qt /plugins/platforms/libqxcb.so
И установить их через apt.
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы
АМИКОН Москва
от 100 000 до 180 000 ₽
ROGII Новосибирск
от 120 000 до 200 000 ₽