@ivan_dubkov

Как установить драйвера для принтера Canon i-sensys MF3010 (USB) на Centos 8?

Добрый день! Я новый пользователь в мире linux, строго не относитесь.

Собственно мне нужно установить дрова для Canon i-sensys MF3010
При установке [root@localhost Загрузки]# rpm -i drova.rpm
ошибка: Неудовлетворенные зависимости:
libpangox-1.0.so.0()(64bit) нужен для cndrvcups-common-2.70-1.x86_64
До этого требовало много пакетов, которые я установил, но на этом пакете я остановился. Нашел его для centos 7 https://pkgs.org/download/libpangox-1.0.so.0 скачал, пытаюсь установить и..
[root@localhost Загрузки]# rpm -i drova.rpm
ошибка: Неудовлетворенные зависимости:
libpangox-1.0.so.0()(64bit) нужен для cndrvcups-common-2.70-1.x86_64
[root@localhost Загрузки]# rpm -i pangox-compat-0.0.2-2.el7.armv7hl.rpm
ошибка: Неудовлетворенные зависимости:
ld-linux-armhf.so.3 нужен для pangox-compat-0.0.2-2.el7.armv7hl
ld-linux-armhf.so.3(GLIBC_2.4) нужен для pangox-compat-0.0.2-2.el7.armv7hl
libX11.so.6 нужен для pangox-compat-0.0.2-2.el7.armv7hl
libgcc_s.so.1(GCC_3.5) нужен для pangox-compat-0.0.2-2.el7.armv7hl
libglib-2.0.so.0 нужен для pangox-compat-0.0.2-2.el7.armv7hl
libgmodule-2.0.so.0 нужен для pangox-compat-0.0.2-2.el7.armv7hl
libgobject-2.0.so.0 нужен для pangox-compat-0.0.2-2.el7.armv7hl
libpango-1.0.so.0 нужен для pangox-compat-0.0.2-2.el7.armv7hl
После ищу один из пакетов, которые он требует. Например libpango-1.0.so.0 , захожу на сайт https://pkgs.org/download/libpango1.0-0, но там только для других дистрибутивов
Берем, что то другое, например ld-linux-armhf.so.3
https://pkgs.org/download/ld-linux-armhf.so.3(GLIB...
Заходим, а там glibc-2.28-72.el8_1.1.armv7hl.rpm, но у он у меня есть! Просто, пробую еще раз его загрузить и конфликт привет

Спасибо за ответы!
  • Вопрос задан
  • 27 просмотров
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы