@Hogun

Не получается установить pip pyserial на MacOs, что делать?

Пытался установить pip pyserial на MacOs, выдает ошибку:
iMac-HOGUN:~ petergalkevych$ pip install pyserial

DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. pip 21.0 will drop support for Python 2.7 in January 2021. More details about Python 2 support in pip can be found at https://pip.pypa.io/en/latest/development/release-... pip 21.0 will remove support for this functionality.
Defaulting to user installation because normal site-packages is not writeable
Requirement already satisfied: pyserial in ./Library/Python/2.7/lib/python/site-packages (3.4)

Говорит что у меня стоит старый Python, хотя я его не устонавливал, в данный момент у меня стоит Python 3.9.0
  • Вопрос задан
  • 58 просмотров
Решения вопроса 1
hottabxp
@hottabxp Куратор тега Python
Миллиардер. Честно, 100 пистонов!
pip3 install pyserial
Ответ написан
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы