FitTech
@FitTech

Не устанавливается нужная ветка через Composer?

Есть проект с composer.json:
{
    "name": "laravel/laravel",
    "type": "project",
    "description": "The Laravel Framework.",
    "keywords": [
        "framework",
        "laravel"
    ],
    "license": "MIT",
    "repositories": [
        {
            "type": "git",
            "url": "git@bitbucket.org:myproject/api.git"
        }
    ],
    "require": {
        "php": "^7.2",
        "myproject/api": "dev-feature/MV-122",
        "myproject/test": "^3.0",
    },
    "require-dev": {
        "phpunit/phpunit": "^8.5"
    },
    "config": {
        "platform": {
            "php": "7.2.5"
        }
    },
    "autoload": {
        "psr-4": {
            "App\\": "app/"
        }
    },
    "autoload-dev": {
        "psr-4": {
            "Tests\\": "tests/"
        }
    },
    "minimum-stability": "dev",
    "prefer-stable": true,
}


На втором проекте который я пытаюсь стянуть через composer имеет ветку feature/MV-122
В require пытался ставить "myproject/api": "dev-feature/MV-122" и "myproject/api": "dev-feature-MV-122".
Установить не получается, постоянно получаю ошибку:

Problem 1
- myproject/test 3.2.1 requires myproject/api ^3.0|^4.0 -> satisfiable by myproject/api[v3.3.2, v3.0.0, v3.0.1, v3.0.2, v3.0.3, v3.0.4, v3.1.0, v3.2.0, v3.3.0, v3.3.1, 4.0.0, 4.0.1, 4.0.2, 4.0.3] but these conflict with your requirements or minimum-stability.
  • Вопрос задан
  • 56 просмотров
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы