@pweveb

Ошибка при установке библиотеки SciPy, как правильно установить?

Устанавливаю значит по рекомендации в книге Гэддиса библиотеки:
Первая библиотека NumPy. Сперва не вышло, но в ошибке вычитал что-то про Visual Studio Tools, скачал, перезагрузил, пошла установка. pandas вышло загрузить без проблем. При установке SciPy выбивает вот такая ошибка
spoiler
5f8b6f8a0ae2b653438395.png
5f8b7024a09b3627188760.png
5f8b702cb0c3f825677185.png
5f8b70351ce2e259699533.png

В PyCharm при установке библиотеки такая же проблема
Как пофикстить? Может я еще про какие-то требования помимо Visual Studio Tools не знаю?

Вот лист библиотек установленных на всякий случай
spoiler
5f8b712cacc76288815898.png


Python 3.9
  • Вопрос задан
  • 80 просмотров
Пригласить эксперта
Ответы на вопрос 3
@Nightfun
У меня подобная ошибка вылетает при установке Discord.py на 3.9. Скачай более раннюю версию пайтона, например, 3.8.3.
Ответ написан
@Andy_U
Ага, плавали. Проблема в том, что на pypi до сих пор нет wheel для Numpy/Python 3.9. Проблема даже не в numpy, а в том, что для CI/CD (по крайней мере для Windows) используется Asure, а вот там Python 3.9 пока не поддерживается. Ждемс. Или ставим готовые whl c lfd.
Ответ написан
@res2001
Developer, ex-admin
Использую Анаконду с уже предустановленными библиотеками. Есть и другие подобные сборки.
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы