@Minazuki

Как исправить конфликт между Apache POI и JavaFX?

Если удаляю requires poi.ooxml; то классы не видят импорты. А если эта строка есть, то вылезает такая ошибка:
Error occurred during initialization of boot layer
java.lang.module.ResolutionException: Modules poi.ooxml and poi export package org.apache.poi.extractor to module javafx.fxmlEmpty
Помогите пожалуйста.

module org.example {
requires javafx.fxml;
requires poi.ooxml;
requires javafx.graphics;

opens org.example to javafx.fxml;
exports org.example;
}
  • Вопрос задан
  • 85 просмотров
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы
Bell Integrator Ростов-на-Дону
от 100 000 до 180 000 ₽
XCritical Software Санкт-Петербург
До 250 000 ₽
Paragon Software Group Санкт-Петербург
от 150 000 ₽
20 окт. 2020, в 22:57
5000 руб./за проект
20 окт. 2020, в 21:37
300000 руб./за проект
20 окт. 2020, в 21:18
500 руб./за проект