@Hanry654

External commonjs vue_commonjs2_vue_root, что делать?

Установил vue-email-editor и скопировал пример с гитхаба:
<template>
  <div class="container">
    <div id="bar">
      <h1>Vue Email Editor (Demo)</h1>

      <button @click="saveDesign">Save Design</button>
      <button @click="exportHtml">Export HTML</button>
    </div>

    <EmailEditor ref="editor" @load="editorLoaded" />
  </div>
</template>

<script>
import { EmailEditor } from 'vue-email-editor'
  
export default {
  components: {
    EmailEditor
  },
  methods: {
    editorLoaded() {
      this.$refs.editor.loadDesign({});
    },
    saveDesign() {
      this.$refs.editor.saveDesign(
        (design) => {
          console.log('saveDesign', design);
        }
      )
    },
    exportHtml() {
      this.$refs.editor.exportHtml(
        (data) => {
          console.log('exportHtml', data);
        }
      )
    }
  }
}
</script>

Но в консоли выдает ошибку:
Uncaught TypeError: external_commonjs_vue_commonjs2_vue_root_Vue_default.a is undefined

package.json
{
  "name": "test",
  "version": "0.1.0",
  "private": true,
  "scripts": {
    "serve": "vue-cli-service serve",
    "build": "vue-cli-service build",
    "lint": "vue-cli-service lint"
  },
  "dependencies": {
    "bootstrap": "^4.5.2",
    "core-js": "^3.6.5",
    "md5": "^2.3.0",
    "vue": "^3.0.0-0",
    "vue-email-editor": "^0.7.2",
    "vue-router": "^4.0.0-0",
    "vuex": "^4.0.0-0"
  },
  "devDependencies": {
    "@vue/cli-plugin-babel": "~4.5.0",
    "@vue/cli-plugin-eslint": "~4.5.0",
    "@vue/cli-plugin-router": "~4.5.0",
    "@vue/cli-plugin-vuex": "~4.5.0",
    "@vue/cli-service": "~4.5.0",
    "@vue/compiler-sfc": "^3.0.0-0",
    "@vue/eslint-config-prettier": "^6.0.0",
    "babel-eslint": "^10.1.0",
    "eslint": "^6.7.2",
    "eslint-plugin-prettier": "^3.1.3",
    "eslint-plugin-vue": "^7.0.0-0",
    "jquery": "^3.5.1",
    "lint-staged": "^9.5.0",
    "node-sass": "^4.12.0",
    "popper.js": "^1.16.1",
    "prettier": "^1.19.1",
    "sass-loader": "^8.0.2"
  }
  • Вопрос задан
  • 45 просмотров
Пригласить эксперта
Ответы на вопрос 1
JRK_DV
@JRK_DV
Рецепты https://codepen.io/jrkdv/full/LKLXdq
скорее всего, потому что используется Vue 3
а для библиотеки "vue-email-editor" нужен Vue 2
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы
24 окт. 2020, в 20:52
27000 руб./за проект
24 окт. 2020, в 20:39
2000 руб./за проект
24 окт. 2020, в 20:39
2000 руб./за проект