@Yzurgzd

Почему возникает ошибка с библиотекой aiogram на Heroku?

2020-09-22T07:25:52.012303+00:00 app[worker.1]:   File "/app/.heroku/python/lib/python3.6/site-packages/aiogram/bot/api.py", line 7, in <module>
2020-09-22T07:25:52.012411+00:00 app[worker.1]:     from .. import types
2020-09-22T07:25:52.012412+00:00 app[worker.1]:   File "/app/.heroku/python/lib/python3.6/site-packages/aiogram/types/__init__.py", line 1, in <module>
2020-09-22T07:25:52.012523+00:00 app[worker.1]:     from . import base
2020-09-22T07:25:52.012525+00:00 app[worker.1]:   File "/app/.heroku/python/lib/python3.6/site-packages/aiogram/types/base.py", line 1
2020-09-22T07:25:52.012535+00:00 app[worker.1]:     from __future__ import annotations
2020-09-22T07:25:52.012536+00:00 app[worker.1]:     ^
2020-09-22T07:25:52.012560+00:00 app[worker.1]: SyntaxError: future feature annotations is not defined
2020-09-22T07:25:52.082465+00:00 heroku[worker.1]: Process exited with status 1
2020-09-22T07:25:52.118341+00:00 heroku[worker.1]: State changed from up to crashed


Все библиотеки установил без ошибок.
  • Вопрос задан
  • 59 просмотров
Пригласить эксперта
Ответы на вопрос 1
@kirillinyakin
Исходя из ошибки, используется Python 3.6, хотя __future__ доступен только вроде как с Python 3.7
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы