PavelUstyugov
@PavelUstyugov
php

Почему не устанавливается Laravel Passport в Laravel 7?

в чем может быть дело? пытаюсь установить laravel passport в Laravel 7 и ругается.

composer require laravel/passport
Using version ^10.0 for laravel/passport
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

Problem 1
- Conclusion: remove laravel/framework v7.28.3
- Conclusion: don't install laravel/framework v7.28.3
- laravel/passport 10.x-dev requires illuminate/support ^8.2 -> satisfiable by laravel/framework[8.x-dev], illuminate/support[8.x-dev, v8.2.0, v8.3.0, v8.4.0, v8.5.0].
- laravel/passport v10.0.0 requires illuminate/support ^8.0 -> satisfiable by laravel/framework[8.x-dev], illuminate/support[8.x-dev, v8.0.0, v8.0.1, v8.0.2, v8.0.3, v8.0.4, v8.1.0, v8.2.0, v8.3.0, v8.4.0, v8.5.0].
- laravel/passport v10.0.1 requires illuminate/support ^8.2 -> satisfiable by laravel/framework[8.x-dev], illuminate/support[8.x-dev, v8.2.0, v8.3.0, v8.4.0, v8.5.0].
- Can only install one of: laravel/framework[8.x-dev, v7.28.3].
- don't install illuminate/support 8.x-dev|don't install laravel/framework v7.28.3
- don't install illuminate/support v8.0.0|don't install laravel/framework v7.28.3
- don't install illuminate/support v8.0.1|don't install laravel/framework v7.28.3
- don't install illuminate/support v8.0.2|don't install laravel/framework v7.28.3
- don't install illuminate/support v8.0.3|don't install laravel/framework v7.28.3
- don't install illuminate/support v8.0.4|don't install laravel/framework v7.28.3
- don't install illuminate/support v8.1.0|don't install laravel/framework v7.28.3
- don't install illuminate/support v8.2.0|don't install laravel/framework v7.28.3
- don't install illuminate/support v8.3.0|don't install laravel/framework v7.28.3
- don't install illuminate/support v8.4.0|don't install laravel/framework v7.28.3
- don't install illuminate/support v8.5.0|don't install laravel/framework v7.28.3
- Installation request for laravel/framework (locked at v7.28.3, required as ^7.24) -> satisfiable by laravel/framework[v7.28.3].
- Installation request for laravel/passport ^10.0 -> satisfiable by laravel/passport[10.x-dev, v10.0.0, v10.0.1].
  • Вопрос задан
  • 177 просмотров
Решения вопроса 1
glaphire
@glaphire
PHP developer
В выводе ошибок написано
Your requirements could not be resolved to an installable set of packages.

Нужно поднять версию ларавель до самой последней 8 дев версии или найти верстю пасспорта, которая совместима с 7й версией. На пакагисте можно посмотреть по каждой версии пакета, как он совместим с другими зависимостями
https://packagist.org/packages/laravel/passport#v9.3.2
Ответ написан
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы