@egorggegor

Как исправить несовместимость версий .NET?

Создал проект, в котором находится бизнес логика, затем создал проект в котором находится интерфейс программы, в проекте интерфейса сделал ссылку на проект с бизнес логикой. Пытаюсь использовать функционал из проекта с бизнес логикой пишет следующую ошибку. Что можно сделать?

Проект "..\EntityAppTest2\EntityAppTest2.csproj" предназначен для целевой платформы "netcoreapp3.1". На него не следует ссылаться в проекте, предназначенном для целевой платформы ".NETFramework,Version=v4.7.2".
EntityAppTestUI
  • Вопрос задан
  • 100 просмотров
Пригласить эксперта
Ответы на вопрос 1
@ayazer
Sr. Software Engineer
у вас одна часть на .нет фреймворке, а вторая - на неткоре. Либо приведите все к чему-то одному, либо используйте нетстандарт нужной версии (тогда библиотека будет совместима и с нетфреймворком, и с неткором).

как я понял с описания - на нетфрейморке у вас именно часть с интерфейсом, потому обновите TargetFramework во втором проекте. файл .sln должен выглядеть как-то

<Project Sdk="Microsoft.NET.Sdk">

  <PropertyGroup>
    <TargetFramework>netstandard2.0</TargetFramework>
  </PropertyGroup>

  <ItemGroup>
    <PackageReference Include="..." Version="..." />
       ...
  </ItemGroup>

  ...

</Project>
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы