Ruslan-Strannik
@Ruslan-Strannik
странствующее животное

Как изменить скрипт Mikrotik?

добрый день.
Есть скрипты на нескольких роутерах Микротик. Появилась необходимость изменить айпи адрес в скрипте.
Как это можно сделать командой в терминале?
В скриптах пока не силен. Пересмотрел кучу примеров, но не нашел как заменить нужное значение в скрипте.
Подкскажите, пожалуйста.

Добавлено.
в теле скрипта нужно изменить одно значение. сам скрипт довольно прост. по нетвочу изменяет айпи адрес в подключении pptp.

скрипт
/system script
add name=ISP1 policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive source=\
"/interface pptp-client set pptp-out1 connect-to=1.1.1.1"
add name=ISP2 policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive source=\
"/interface pptp-client set pptp-out1 connect-to=2.2.2.2"
/tool netwatch
add down-script=ISP2 host=2.2.2.2 up-script=ISP1

вот адрес 2.2.2.2 необходимо изменить.

недавно реализовал механизм массового подключения к микротикам по ssh и выполнения нужных команд.
вот тут проблема )) не знаю как команду выразить.

Пока сделал удалить скрипт и создать обновленный. а в нетвоче с этим проще
/tool netwatch set [find host=2.2.2.2] host=3.3.3.3
  • Вопрос задан
  • 139 просмотров
Решения вопроса 2
poisons
@poisons
Если скрипт хранится на микротике, то нет возможности поменять только его часть. Его нужно прочитать внешней системой целиком, поменять нужную часть и залить обратно.
В вашей ситуации можно указать доменное имя, даже несуществующее, и добавить статичную запись в днс с нужным ip. Подменяя ip вы решите вашу задачу.
Ответ написан
@graf_Alibert
В терминале вводите
/system script edit [find name=ISP1] source
Откроется редактор, меняете нужный вам параметр и Ctrl+O для выхода и сохранения изменений.
Ответ написан
Пригласить эксперта
Ответы на вопрос 1
@kprohorow
Если 1.1.1.1 и 2.2.2.2 в вашем случае это внешние адреса головного сервера pptp под управлением RouterOS то можно использовать встроенную функцию dyndns.
И обойтись без скриптов вообще.
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы