BonBonSlick
@BonBonSlick
Vanilla Web Architect

Nginx unmet depndencies?

Отвалилися nginx на ровном месте linux перестал видеть nginx - v command not found

Пробовал добавить пути
bonbon@debian:~$ PATH=$PATH:~/usr/sbin
bonbon@debian:~$ PATH=$PATH:~/usr/local/bin
bonbon@debian:~$ PATH=$PATH:~/usr/local/sbin
bonbon@debian:~$ echo $PATH
/home/bonbon/.yarn/bin:/home/bonbon/.config/yarn/global/node_modules/.bin:/opt/gradle/gradle-6.3/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games:/home/bonbon/usr/bin:/home/bonbon/usr/sbin:/home/bonbon/usr/local/bin:/home/bonbon/usr/local/sbin


Пробовал сделать
apt-get update
apt-get upgrade


sudo apt -o Dpkg::Options::="--force-overwrite" upgrade nginx


sudo apt-get install -f
sudo dpkg --configure -a
sudo apt-get install -f


sudo apt-get clean
sudo apt-get autoclean


sudo apt-get remove --dry-run nginx

Все попытки устанвоить по новой, апгрейдить приводят к ошибке

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 nginx : Depends: nginx-core (< 1.18.0-4+ubuntu19.10.1+deb.sury.org+1.1~) but it is not going to be installed or
                  nginx-full (< 1.18.0-4+ubuntu19.10.1+deb.sury.org+1.1~) but it is not going to be installed or
                  nginx-light (< 1.18.0-4+ubuntu19.10.1+deb.sury.org+1.1~) but it is not going to be installed or
                  nginx-extras (< 1.18.0-4+ubuntu19.10.1+deb.sury.org+1.1~) but it is not going to be installed
         Depends: nginx-core (>= 1.18.0-4+ubuntu19.10.1+deb.sury.org+1) but it is not going to be installed or
                  nginx-full (>= 1.18.0-4+ubuntu19.10.1+deb.sury.org+1) but it is not going to be installed or
                  nginx-light (>= 1.18.0-4+ubuntu19.10.1+deb.sury.org+1) but it is not going to be installed or
                  nginx-extras (>= 1.18.0-4+ubuntu19.10.1+deb.sury.org+1) but it is not going to be installed
E: Broken packages


bonbon@debian:~$ sudo apt purge nginx
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package 'nginx' is not installed, so not removed
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

bonbon@debian:~$ sudo apt-get install nginx nginx-common nginx-full nginx-core
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 nginx-core : Depends: libnginx-mod-http-geoip (= 1.18.0-4+ubuntu19.10.1+deb.sury.org+1) but it is not going to be installed
              Depends: libnginx-mod-stream-geoip (= 1.18.0-4+ubuntu19.10.1+deb.sury.org+1) but it is not going to be installed
              Depends: libc6 (>= 2.28) but 2.24-11+deb9u4 is to be installed
E: Unable to correct problems, you have held broken packages.
bonbon@debian:~$ sudo apt-get install nginx nginx-common nginx-full nginx-core libnginx-mod-http-geopip
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package libnginx-mod-http-geopip


Думаю отвалился как и ОС недавно из за windows или ssd битых секторов.

Требует зависимости которых нет
# deb cdrom:[Debian GNU/Linux 9.5.0 _Stretch_ - Official amd64 DVD Binary-1 201$

deb http://debian.volia.net/debian/ stretch main
deb-src http://debian.volia.net/debian/ stretch main

deb http://security.debian.org/debian-security stretch/updates main contrib
deb-src http://security.debian.org/debian-security stretch/updates main contrib

# stretch-updates, previously known as 'volatile'
deb http://debian.volia.net/debian/ stretch-updates main contrib
deb-src http://debian.volia.net/debian/ stretch-updates main contrib

#deb http://httpredir.debian.org/debian jessie-backports main contrib no n-free
.
  • Вопрос задан
  • 44 просмотра
Решения вопроса 1
Lynn
@Lynn
nginx, js, css
Судя по странной версии (1.18.0-4+ubuntu19.10.1+deb.sury.org+1) nginx был поставлен из какого-то стороннего репозитория. Стоит попробовать отключить его и поставить nginx из официального репозитория debian.
Ответ написан
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы