VicTHOR
@VicTHOR
(╮°-°)╮┳━━┳ ( ╯°□°)╯ ┻━━┻

Как правильно установить pgadmin?

следую этой статье https://computingforgeeks.com/how-to-install-pgadm...
Проблема возникла на step 3
spoiler
[root@devserver pgsql]# dnf install pgadmin4
Last metadata expiration check: 0:04:00 ago on Mon 06 Apr 2020 08:59:25 PM MSK.
Error: 
 Problem 1: cannot install the best candidate for the job
  - nothing provides python3-bcrypt needed by pgadmin4-web-4.20-1.rhel8.noarch
  - nothing provides python3-pynacl needed by pgadmin4-web-4.20-1.rhel8.noarch
  - nothing provides python3-blinker >= 1.4 needed by pgadmin4-web-4.20-1.rhel8.noarch
 Problem 2: package pgadmin4-4.20-1.rhel8.x86_64 requires pgadmin4-web, but none of the providers can be installed
  - cannot install the best candidate for the job
  - nothing provides python3-alembic needed by pgadmin4-web-4.16-1.rhel8.noarch
  - nothing provides pgadmin4-python3-unittest2 needed by pgadmin4-web-4.16-1.rhel8.noarch
  - nothing provides python3-blinker >= 1.4 needed by pgadmin4-web-4.16-1.rhel8.noarch
  - nothing provides python3-beautifulsoup4 >= 4.4.1 needed by pgadmin4-web-4.16-1.rhel8.noarch
  - nothing provides python3-flask-sqlalchemy >= 2.3.2 needed by pgadmin4-web-4.16-1.rhel8.noarch
  - nothing provides python3-alembic needed by pgadmin4-web-4.16-2.rhel8.noarch
  - nothing provides python3-unittest2 needed by pgadmin4-web-4.16-2.rhel8.noarch
  - nothing provides python3-blinker >= 1.4 needed by pgadmin4-web-4.16-2.rhel8.noarch
  - nothing provides python3-beautifulsoup4 >= 4.4.1 needed by pgadmin4-web-4.16-2.rhel8.noarch
  - nothing provides python3-alembic needed by pgadmin4-web-4.17-1.rhel8.noarch
  - nothing provides python3-unittest2 needed by pgadmin4-web-4.17-1.rhel8.noarch
  - nothing provides python3-blinker >= 1.4 needed by pgadmin4-web-4.17-1.rhel8.noarch
  - nothing provides python3-beautifulsoup4 >= 4.4.1 needed by pgadmin4-web-4.17-1.rhel8.noarch
  - nothing provides python3-alembic needed by pgadmin4-web-4.17-2.rhel8.noarch
  - nothing provides python3-bcrypt needed by pgadmin4-web-4.17-2.rhel8.noarch
  - nothing provides python3-pynacl needed by pgadmin4-web-4.17-2.rhel8.noarch
  - nothing provides python3-unittest2 needed by pgadmin4-web-4.17-2.rhel8.noarch
  - nothing provides python3-blinker >= 1.4 needed by pgadmin4-web-4.17-2.rhel8.noarch
  - nothing provides python3-beautifulsoup4 >= 4.4.1 needed by pgadmin4-web-4.17-2.rhel8.noarch
  - nothing provides python3-alembic needed by pgadmin4-web-4.18-1.rhel8.noarch
  - nothing provides python3-bcrypt needed by pgadmin4-web-4.18-1.rhel8.noarch
  - nothing provides python3-pynacl needed by pgadmin4-web-4.18-1.rhel8.noarch
  - nothing provides python3-unittest2 needed by pgadmin4-web-4.18-1.rhel8.noarch
  - nothing provides python3-blinker >= 1.4 needed by pgadmin4-web-4.18-1.rhel8.noarch
  - nothing provides python3-beautifulsoup4 >= 4.4.1 needed by pgadmin4-web-4.18-1.rhel8.noarch
  - nothing provides python3-bcrypt needed by pgadmin4-web-4.19-1.rhel8.noarch
  - nothing provides python3-pynacl needed by pgadmin4-web-4.19-1.rhel8.noarch
  - nothing provides python3-blinker >= 1.4 needed by pgadmin4-web-4.19-1.rhel8.noarch
  - nothing provides python3-bcrypt needed by pgadmin4-web-4.20-1.rhel8.noarch
  - nothing provides python3-pynacl needed by pgadmin4-web-4.20-1.rhel8.noarch
  - nothing provides python3-blinker >= 1.4 needed by pgadmin4-web-4.20-1.rhel8.noarch
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

я не знаю что я сделал командой dnf -qy module disable postgresql и в чем особенность установки rpm пакетов через dnf по ссылке...
Каковы правильные действия?
  • Вопрос задан
  • 69 просмотров
Решения вопроса 2
fzfx
@fzfx
18,5 дм
это уже сделано?
Ответ написан
VicTHOR
@VicTHOR Автор вопроса
(╮°-°)╮┳━━┳ ( ╯°□°)╯ ┻━━┻
вместо pgadmin ушел на phpPgAdmin
Ответ написан
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы