@ipoluda

Не работает проброс портов на Mikrotik, когда подключен как VPN клиент?

Есть роутер RB950, он является шлюзом для небольшого офиса. Микрот подключен к PPTP серверу как клиент и весь офис выходит в интернет через этот ВПН сервер. В туннель завернуто так: все соединения с src - ЛАН и dst - НЕ ЛАН маркируются и маркированные пакеты отправляются в туннель. При этом, конечно же, прописан маршрут по умолчанию, который направляет маркированный трафик через шлюз=ВПН. Пытаюсь пробросить порт, чтобы извне (когда стучусь на внешний стат. адрес) получить доступ к компьютеру в локалке. Проблема в том что когда маршрута по умолчанию для ВПН нет, всё работает отлично. Как только я прописываю маршрут по умолчанию для ВПН - проброс перестает работать. Раньше так же делал и всё работало, а сейчас не хочет. В чём может быть проблема?
P.S. На втором скрине видно правила маскарадинга и правило проброса.
Фаервол пробовал выключать, проблема НЕ в нем точно.

5e8b071851691358576423.png
5e8b071f8103f427907127.png
5e8b0727a3552617122938.png
5e8b072e48336732107978.png
  • Вопрос задан
  • 93 просмотра
Пригласить эксперта
Ответы на вопрос 1
@Wexter
потому что в обратную сторону у вас мангл ловит пакет по этому правилу и отправляет через впн.
делайте маркировку соединений на входе со стороны интернета и обратную маркировку маршрута в таблицу main для соединений с маркировкой на входе.
правило неточное, допилите под себя
/ip firewall mangle add chain=prerouting in-interface=INTERNET action=mark-connection new-connection-mask=from_internet
/ip firewall mangle add chain=prerouting src-address=192.168.0.0/24 connection-mark=from_internet action=mark-routing new-routing-mark=main

И не надо использовать netmap для проброса портов, dst-nat прекрасно работает.
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы