fapchat
@fapchat

Как установить Libevent для php?

Следую вот этой статьи

make && sudo make install
...
In file included from /usr/include/php/20151012/Zend/zend.h:31:0,
from /usr/include/php/20151012/main/php.h:36,
from /home/fapchat/Загрузки/uuid-1.6.2/pecl-event-libevent/libevent.c:26:
/home/fapchat/Загрузки/uuid-1.6.2/pecl-event-libevent/libevent.c: In function ‘zif_event_set’:
/usr/include/php/20151012/Zend/zend_types.h:551:25: warning: passing argument 2 of ‘zend_hash_index_find’ makes integer from pointer without a cast [-Wint-conversion]
...
In file included from /usr/include/php/20151012/Zend/zend.h:31:0,
from /usr/include/php/20151012/main/php.h:36,
from /home/fapchat/Загрузки/uuid-1.6.2/pecl-event-libevent/libevent.c:26:
/home/fapchat/Загрузки/uuid-1.6.2/pecl-event-libevent/libevent.c: In function ‘zif_event_buffer_new’:
/usr/include/php/20151012/Zend/zend_types.h:551:25: warning: passing argument 2 of ‘zend_hash_index_find’ makes integer from pointer without a cast [-Wint-conversion]
...

ZEND_API zval* ZEND_FASTCALL zend_hash_index_find(const HashTable *ht, zend_ulong h);
^~~~~~~~~~~~~~~~~~~~
In file included from /usr/include/php/20151012/Zend/zend.h:31:0,
from /usr/include/php/20151012/main/php.h:36,
from /home/fapchat/Загрузки/uuid-1.6.2/pecl-event-libevent/libevent.c:26:
/home/fapchat/Загрузки/uuid-1.6.2/pecl-event-libevent/libevent.c: In function ‘zif_event_buffer_fd_set’:
/usr/include/php/20151012/Zend/zend_types.h:551:25: warning: passing argument 2 of ‘zend_hash_index_find’ makes integer from pointer without a cast [-Wint-conversion]
#define Z_RES(zval) (zval).value.res

(весь код не показываю, т.к. ответ не может превысить 10к символов)

откуда эти
warnings
? в гугле ничего полезного не нашёл(по-крайней мере по некоторым
warning
, все не гуглил)

Библиотеку либивент установил(то есть скачал архив с сайта libevent.org/, распаковал, написал ./configure
make
make install
)

В статье на гитхабе написано, что нужна библетоека(library) либивент и дана ссылка на этот сайт
This extension requires » libevent library. Minimal required version is 1.4.0.

Может это и есть либивент?
  • Вопрос задан
  • 25 просмотров
Пригласить эксперта
Ответы на вопрос 1
nokimaro
@nokimaro Куратор тега PHP
По первой ссылке указано что нужно установить и скомпилить php7.x-dev и libevent-dev

Pre-requisites (only for linux) :
sudo apt-get install php7.0-dev gcc make libevent-dev


А потом уже компилить само расширение. Ествественно dev-версию РНР надо ставить свою, 7.0, 7.2, 7.4 и тд
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы
26 мая 2020, в 02:01
4500 руб./за проект
26 мая 2020, в 00:42
10000 руб./за проект
25 мая 2020, в 22:16
3000 руб./за проект