Как исправить то, что file_get_contents отдает ошибку HTTP request failed! HTTP/1.1 426 Upgrade Required?

Добрый вечер!
При попытке получить содержимое страницы с помощью конструкции:
file_get_contents($url, null, stream_context_create(['https' => ['method' => 'GET']]));

получаю ошибку HTTP request failed! HTTP/1.1 426 Upgrade Required. Я так понимаю, что сервер требует обращаться через какой-то другой протокол, но как задать протокол в функции file_get_contents?
  • Вопрос задан
  • 77 просмотров
Пригласить эксперта
Ответы на вопрос 2
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы