Tesla4o
@Tesla4o
Без пользы жизнь - безвременная смерть... В. Гете

Как в коде определить версию Ubuntu?

Есть код который для libv8-dev работает на 18 версии убунты. Но на 19.10 уже не работает потому что версия библиотеки libv8-dev на ней другая. Поэтому пришлось переписывать код под новую. Но так как нужно сделать что бы работало на обеих версиях я думаю что просто в одном файле написать под обе версии. И разделить код переключателем #ifdef. Только не могу найти ни где по какому дефайну делать переключение кода в зависимости от версии Ubuntu.
  • Вопрос задан
  • 220 просмотров
Решения вопроса 1
firedragon
@firedragon
Senior .NET developer
Стандартное решение это использование autoconf
Он сам в состоянии определить библиотеки в системе, и назначить нужные дефайны

https://www.gnu.org/software/autoconf/manual/
Ответ написан
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы