@uuuu

Как установить конкретную версию MySQL в Linux?

Работал сервер на VDS, потом перестал. При попытке запуска пишет:

DatabaseWorkerPool.cpp:58 in DatabaseWorkerPool FATAL ERROR:
Used MySQL library version (5.7.29) does not match the version used to compile ServerCore (5.7.28)

Из ошибки понял, что версии MySQL не соответствуют. Как установить определённую версию MySQL, а именно 5.7.28?
  • Вопрос задан
  • 108 просмотров
Решения вопроса 1
@dronmaxman
VoIP Administrator
Интересно что это за серверное ПО - ServerCore. Вообще такое минорное обновление не должно влиять на совместимость. Скорее всего ServerCore был установлен из исходников и скопилен с поддержкой версии sql установленной в тот момент. (library 5.7.28). Вам надо перекопилить ServerCore. Или откатиться на прежнюю версию SQL. А вообще autoupgrade это зло) Такие дела надо делать с бекапами и тестированием.

https://linoxide.com/linux-command/install-specifi...
Ответ написан
Пригласить эксперта
Ответы на вопрос 1
CityCat4
@CityCat4
У тролля даже мозги - и то каменные!
Используя пакетный менеджер, естественно, который в Вашем дистрибе. Или собирая руками через команду сборки, если это source-based. Ну или уж, если полный хардкор - качаем сырцы с сайта, распаковываем, собираем по инструкции...
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы