@olegan_09

Ошибка при установке пакетов npm i на мак и gulp, как исправить?

Не получается установить на мак пакеты npm, также не устанавливается gulp. Node последняя версия, npm - тоже. При вводе команды sudo npm i или npm i выдает следующие ошибки:

npm WARN saveError ENOENT: no such file or directory, open '/Users/mac/package.json'
npm WARN enoent ENOENT: no such file or directory, open '/Users/mac/package.json'
npm WARN mac No description
npm WARN mac No repository field.
npm WARN mac No README data
npm WARN mac No license field.

При установке gulp (sudo npm install -g gulp) след ошибки

npm WARN deprecated gulp-util@3.0.8: gulp-util is deprecated - replace it, following the guidelines at https://medium.com/gulpjs/gulp-util-ca3b1f9f9ac5
npm WARN deprecated graceful-fs@3.0.11: please upgrade to graceful-fs 4 for compatibility with current and future versions of Node.js
npm WARN deprecated minimatch@2.0.10: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
npm WARN deprecated minimatch@0.2.14: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
npm WARN deprecated graceful-fs@1.2.3: please upgrade to graceful-fs 4 for compatibility with current and future versions of Node.js
npm WARN deprecated natives@1.1.3: This module relies on Node.js's internals and will break at some point. Do not use it, and update to graceful-fs@4.x.
/usr/local/bin/gulp -> /usr/local/lib/node_modules/gulp/bin/gulp.js
+ gulp@3.9.1
updated 1 package in 8.278s

Подскажите как исправить?
  • Вопрос задан
  • 1206 просмотров
Пригласить эксперта
Ответы на вопрос 2
mak_ufo
@mak_ufo
Локально вы не можете поставить пакеты из-за отсутствия package.json в папке, откуда вызывается npm i

Глобально пакеты ставятся нормально. WARN - это предупреждение, а не ошибка.

P.S. В следующий раз кидайте скрины консоли или заливайте логи на pastebin. Так читабельней
Ответ написан
@olegan_09 Автор вопроса
такие же ошибки были при обновлении NPM командой: sudo npm i npm.
Потом все встало командой: sudo npm install npm -g
Но это не помогает при установке пакетов
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы