poisons
@poisons

Mikrotik + vrrp. Почему появляется лишний dhcp-client на vrrp интерфейсе?

Дано
1) GNS3vm
2) 2xCHR, 1 switch
Схема проста до безобразия
0nbahczuia8scufsxjbjoeijsje.png&key=bb80
Портянка конфигов
МТ1
/interface vrrp
add interface=ether2 name=vrrp1 priority=101
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip pool
add name=dhcp_pool0 ranges=192.168.50.10-192.168.50.253
/ip dhcp-server
add address-pool=dhcp_pool0 disabled=no interface=ether2 name=dhcp1
/ip address
add address=192.168.50.254 interface=vrrp1 network=192.168.50.254
add address=192.168.50.1/24 interface=ether2 network=192.168.50.0
/ip dhcp-client
add disabled=no interface=ether1
/ip dhcp-server network
add address=192.168.50.0/24 dns-server=192.168.50.254 gateway=192.168.50.254
/ip dns
set allow-remote-requests=yes
/ip firewall nat
add action=masquerade chain=srcnat out-interface=ether1
/system package update
set channel=bugfix

МТ2
/interface vrrp
add interface=ether2 name=vrrp1
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip pool
add name=dhcp_pool0 ranges=192.168.50.10-192.168.50.253
/ip dhcp-server
add address-pool=dhcp_pool0 delay-threshold=5s disabled=no interface=ether2 name=dhcp1
/ip address
add address=192.168.50.254 interface=vrrp1 network=192.168.50.254
add address=192.168.50.2/24 interface=ether2 network=192.168.50.0
/ip dhcp-client
add disabled=no interface=ether1
/ip dhcp-server network
add address=192.168.50.0/24 dns-server=192.168.50.254 gateway=192.168.50.254
/ip dns
set allow-remote-requests=yes
/ip firewall nat
add action=masquerade chain=srcnat out-interface=ether1
/system package update
set channel=bugfix

Проверял на версии 6.39.3 и 6.40.5.
Что собственно происходит - если поднять такую конфигурацию, то все работает корректно, один из тиков считает себя мастером, т.к. приоритет у него выше, трафик ходит, все хорошо. Но как только я выполняю одно из следущих действий
1) Перезагрузка одного chr или сразу двух
2) Включение/выключение физического интерфейса, разрыв линка между одним из chr и свичем
На одном из chr или сразу на обоих появляется dhcp client на vrrp1 интерфейсе и vrrp начинает работать вот так
interface vrrp print
Flags: X - disabled, I - invalid, R - running, M - master, B - backup
 #     NAME           INTERFACE           MAC-ADDRESS       VRID PRIORITY INTERVAL             VERSION V3-PROTOCOL
 0  RM ;;; received packet from 192.168.50.1 misconfigured IP addresses [192.168.50.254](my) != [192.168.50.253...
       vrrp1          ether2              00:00:5E:00:01:01    1      100 1s                   3       ipv4

В чем заключается проблема? Кто такое ловил и можно ли побороть?
  • Вопрос задан
  • 1144 просмотра
Пригласить эксперта
Ответы на вопрос 1
vasilevkirill
@vasilevkirill
Сертифицированный тренер MikroTik TR0417
Добрый день,
очень смахивает, что у вас меняется мак адрес.
Удалите явно dhcp-client
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы