des1roer
@des1roer
ученье - свет, а неученье - приятный полумрак

Ruby on Rails rake aborted?

>
rake db:migrate --trace
rake aborted!
NameError: undefined local variable or method `__dir__' for main:Object
F:/OpenServer/domains/localhost/webrails/config/boot.rb:1:in `<top (required)>' F:/OpenServer/domains/localhost/webrails/config/application.rb:1:in `require_relative'
F:/OpenServer/domains/localhost/webrails/config/application.rb:1:in `<top (required)>'
F:/OpenServer/domains/localhost/webrails/Rakefile:4:in `require_relative'
F:/OpenServer/domains/localhost/webrails/Rakefile:4:in `<top (required)>'
C:/Ruby19/lib/ruby/gems/1.9.1/gems/rake-12.0.0/lib/rake/rake_module.rb:28:in `load'
C:/Ruby19/lib/ruby/gems/1.9.1/gems/rake-12.0.0/lib/rake/rake_module.rb:28:in `load_rakefile'
C:/Ruby19/lib/ruby/gems/1.9.1/gems/rake-12.0.0/lib/rake/application.rb:687:in `raw_load_rakefile'
C:/Ruby19/lib/ruby/gems/1.9.1/gems/rake-12.0.0/lib/rake/application.rb:96:in `block in load_rakefile'
C:/Ruby19/lib/ruby/gems/1.9.1/gems/rake-12.0.0/lib/rake/application.rb:178:in `standard_exception_handling'
C:/Ruby19/lib/ruby/gems/1.9.1/gems/rake-12.0.0/lib/rake/application.rb:95:in `load_rakefile'
C:/Ruby19/lib/ruby/gems/1.9.1/gems/rake-12.0.0/lib/rake/application.rb:79:in `block in run'
C:/Ruby19/lib/ruby/gems/1.9.1/gems/rake-12.0.0/lib/rake/application.rb:178:in `standard_exception_handling'
C:/Ruby19/lib/ruby/gems/1.9.1/gems/rake-12.0.0/lib/rake/application.rb:77:in `run'
C:/Ruby19/lib/ruby/gems/1.9.1/gems/rake-12.0.0/exe/rake:27:in `<top (required)>'

C:/Ruby19/bin/rake:23:in `load'
C:/Ruby19/bin/rake:23:in `<main>'


Использую openserver и win10

> rails -v
Rails 5.0.1

> gem -v
1.8.24

> rake
rake aborted!
  • Вопрос задан
  • 390 просмотров
Пригласить эксперта
Ответы на вопрос 3
b0nn1e
@b0nn1e
Alcohol & Ruby on Rails
Первое чему учат молодого Ruby on Rails разработчика - это установить и настроить себе Ubuntu.
Ответ написан
OnYourLips
@OnYourLips
C:/Ruby19
Обновите Ruby. Ваша версия очень старая.
__dir__ в 2.0 появился.
Ответ написан
@unabl4
ruby on rails web dev
Как вы установили 5-ые рельсы на руби 1.9.1? Минимальная поддержка с 2.2.х. 1.9.1 - жуткое старье.
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы
iGooods.ru Санкт-Петербург
от 120 000 до 180 000 ₽
SberMarket Москва
До 220 000 ₽
Frogogo Москва
от 100 000 ₽
18 февр. 2020, в 12:30
5000 руб./за проект
18 февр. 2020, в 12:24
40000 руб./за проект