Как настроить postfix, для отправки уведомлений о голосовом сообщении?

Хочу настроить отправку уведомлений на поту пользователям, на тестовой машине у меня это получилось, а на боевом сервере не получается настроить.. помогите в решении проблемы..

Выкладываю лог Postfix
Jan 31 12:28:24 localhost postfix/cleanup[6594]: C131B4359F: message-id=<20160131092824.C131B4359F@FreePBX_Moscow.localdomain>
Jan 31 12:28:24 localhost postfix/qmgr[4187]: C131B4359F: from=, size=924, nrcpt=1 (queue active)
Jan 31 12:28:24 localhost postfix/local[6623]: C131B4359F: to=, orig_to=, relay=local, delay=0.45, delays=0.37/0/0/0.08, dsn=2.0.0, status=sent (delivered to mailbox)
Jan 31 12:28:24 localhost postfix/qmgr[4187]: C131B4359F: removed
Jan 31 12:29:12 localhost sSMTP[8768]: Creating SSL connection to host
Jan 31 12:29:12 localhost sSMTP[8768]: SSL not working: unknown message digest algorithm (7)
Jan 31 12:29:12 localhost sSMTP[8768]: Cannot open smtp.gmail.com:587

Изначально была такая ошибка sSMTP[1332]: SSL not working: certificate verify failed (20)
потом я добавил строку TLS_CA_File=/etc/pki/tls/certs/ca-bundle.crt
ошибки поменялись... в интернете ничего особого найти по ней не могу...Тестовое сообщение
mail -s test mail@yandex.ru < /dev/null приходит на почту, но если оставить сообщение то ничего не происходит.

nano /etc/postfix/main.cf

smtp_sasl_auth_enable = yes
smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd
smtp_sasl_security_options = noanonymous

smtp_tls_security_level = secure
smtp_tls_mandatory_protocols = TLSv1
smtp_tls_mandatory_ciphers = high
smtp_tls_secure_cert_match = nexthop
smtp_tls_CAfile = /etc/pki/tls/certs/ca-bundle.crt
relayhost = smtp.gmail.com:587

nano /etc/postfix/main.conf

relayhost = [smtp.example.com]:port
smtp_sasl_auth_enable = yes
smtp_sasl_mechanism_filter =
smtp_sasl_password_maps = hash:/etc/postfix/saslpass
smtp_sasl_security_options = noanonymous
  • Вопрос задан
  • 357 просмотров
Пригласить эксперта
Ответы на вопрос 1
SSL not working: unknown message digest algorithm
Это указывает на то, что возможно у Вас установлена устаревшая версия openssl. Попробуйте обновить её.
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы