kruchkov-alexandr
@kruchkov-alexandr
VSAT engineer

Cisco Catalyst 2950, трафик в одном Vlan?

Добрый день. Изучаю cisco маршрутизаторы.

Имеется catalyst 2950, имеется несколько «специализированных» устройств с портами ethernet. Эти модемы, назовем их так, используют разнообразные протоколы, так же используют броадкаст.

Я создал несколько vlan чтобы разделить новые подсети. В дефолтном #1 использую местную локалку, остальные vlan #2 #3 использую для этих модемов.

Но вот беда — трафик нужный не идет, насколько я понимаю от порта к порту в одном vlan.

При этом если эти модемы соединять не через отдельные vlan циски, а через 8и портовые свитчи длинк, то все прекрасно работает.

Что я делают не так?

Vlan
Switch#sh vl<br/>
<br/>
VLAN Name Status Ports<br/>
---- -------------------------------- --------- -------------------------------<br/>
1 default active Fa0/2, Fa0/3, Fa0/4, Fa0/5<br/>
 Fa0/6, Fa0/7, Fa0/8, Fa0/15<br/>
 Fa0/16, Fa0/17, Fa0/18, Fa0/19<br/>
 Fa0/20, Fa0/21, Fa0/22, Fa0/23<br/>
 Fa0/24<br/>
2 cisco_vlan_2 active Fa0/9, Fa0/10, Fa0/11<br/>
3 cisco_vlan_3 active Fa0/12, Fa0/13, Fa0/14<br/>
1002 fddi-default act/unsup<br/>
1003 token-ring-default act/unsup<br/>
1004 fddinet-default act/unsup<br/>
1005 trnet-default act/unsup<br/>
<br/>
VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2<br/>
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------<br/>
1 enet 100001 1500 - - - - - 0 0<br/>
2 enet 100002 1500 - - - - - 0 0<br/>
3 enet 100003 1500 - - - - - 0 0<br/>
1002 fddi 101002 1500 - - - - - 0 0<br/>
1003 tr 101003 1500 - - - - - 0 0<br/>
1004 fdnet 101004 1500 - - - ieee - 0 0<br/>
<br/>
VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2<br/>
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------<br/>
1005 trnet 101005 1500 - - - ibm - 0 0<br/>
<br/>
Remote SPAN VLANs<br/>
------------------------------------------------------------------------------<br/>
<br/>
Primary Secondary Type Ports<br/>
------- --------- ----------------- ------------------------------------------<br/>
<br/>
Switch#


Конфиг свича:
Switch#sh ru<br/>
Building configuration...<br/>
<br/>
Current configuration : 1711 bytes<br/>
!<br/>
version 12.1<br/>
no service pad<br/>
service timestamps debug uptime<br/>
service timestamps log uptime<br/>
no service password-encryption<br/>
!<br/>
hostname Switch<br/>
!<br/>
!<br/>
ip subnet-zero<br/>
!<br/>
!<br/>
spanning-tree mode pvst<br/>
no spanning-tree optimize bpdu transmission<br/>
spanning-tree extend system-id<br/>
!<br/>
!<br/>
!<br/>
!<br/>
interface FastEthernet0/1<br/>
 spanning-tree portfast<br/>
!<br/>
interface FastEthernet0/2<br/>
 spanning-tree portfast<br/>
!<br/>
interface FastEthernet0/3<br/>
 spanning-tree portfast<br/>
!<br/>
interface FastEthernet0/4<br/>
 spanning-tree portfast<br/>
!<br/>
interface FastEthernet0/5<br/>
 spanning-tree portfast<br/>
!<br/>
interface FastEthernet0/6<br/>
 spanning-tree portfast<br/>
!<br/>
interface FastEthernet0/7<br/>
 spanning-tree portfast<br/>
!<br/>
interface FastEthernet0/8<br/>
 spanning-tree portfast<br/>
!<br/>
interface FastEthernet0/9<br/>
 switchport access vlan 2<br/>
 spanning-tree portfast<br/>
!<br/>
interface FastEthernet0/10<br/>
 switchport access vlan 2<br/>
 spanning-tree portfast<br/>
!<br/>
interface FastEthernet0/11<br/>
 switchport access vlan 2<br/>
 spanning-tree portfast<br/>
!<br/>
interface FastEthernet0/12<br/>
 switchport access vlan 3<br/>
 spanning-tree portfast<br/>
!<br/>
interface FastEthernet0/13<br/>
 switchport access vlan 3<br/>
 spanning-tree portfast<br/>
!<br/>
interface FastEthernet0/14<br/>
 switchport access vlan 3<br/>
 spanning-tree portfast<br/>
!<br/>
interface FastEthernet0/15<br/>
 spanning-tree portfast<br/>
!<br/>
interface FastEthernet0/16<br/>
 spanning-tree portfast<br/>
!<br/>
interface FastEthernet0/17<br/>
 spanning-tree portfast<br/>
!<br/>
interface FastEthernet0/18<br/>
 spanning-tree portfast<br/>
!<br/>
interface FastEthernet0/19<br/>
!<br/>
interface FastEthernet0/20<br/>
!<br/>
interface FastEthernet0/21<br/>
!<br/>
interface FastEthernet0/22<br/>
!<br/>
interface FastEthernet0/23<br/>
!<br/>
interface FastEthernet0/24<br/>
!<br/>
interface Vlan1<br/>
 no ip address<br/>
 no ip route-cache<br/>
 shutdown<br/>
!<br/>
interface Vlan2<br/>
 no ip address<br/>
 no ip route-cache<br/>
!<br/>
ip http server<br/>
!<br/>
line con 0<br/>
line vty 5 15<br/>
!<br/>
!<br/>
end<br/>
<br/>
Switch#
  • Вопрос задан
  • 4928 просмотров
Пригласить эксперта
Ответы на вопрос 5
omnimod
@omnimod
Возможно модемы используют нестандартный MTU (>1500). На «глупом» коммутаторе может быть автоматически разрешен Jumbo Frames, попробуйте разрешить и на Cisco.
Ответ написан
PooFF
@PooFF
для полноты картины
sh int stats
sh int status
sh span blockedports
sh mac-add
Ответ написан
mikes
@mikes
вланы везде нативные?
Ответ написан
@EgoretZ
Исходя из вывода sh run, предлагаю сделать следующее:
— во-первых, внести в базу вланов vlan 3 — он у вас вообще не определён. Это обязательно нужно сделать.
— во-вторых, циска настоятельно рекомендует говорить команду «switchport mode access», если вы прибиваете порт к влану.
Ответ написан
mastini
@mastini
Расскажите, в каких портах у вас торчат эти модемы? И как вы проверяете их работоспособность?
Ответ написан
Комментировать
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы