Xeffer
@Xeffer
frontend dev

Почему coverage в vitest не видит нужную версию node и падает?

Ни в какую не запускается vitest coverage v8. При установке возникли проблемы, которые решил --legacy-peer-deps.
Далее возникла проблема, при node -v, выдающим v18.20.2 vitest пишет следующее:

RUN  v1.5.0 /media/ejex/data/web/datepickertest
      Coverage enabled with v8

stdout | src/components/__tests__/Datepicker.spec.ts > Datepicker > renders properly
day 4

 ✓ src/components/__tests__/Datepicker.spec.ts (1)
   ✓ Datepicker (1)
     ✓ renders properly

 Test Files  1 passed (1)
      Tests  1 passed (1)
   Start at  13:45:27
   Duration  1.03s (transform 164ms, setup 1ms, collect 232ms, tests 47ms, environment 419ms, prepare 99ms)


⎯⎯⎯⎯⎯⎯⎯⎯⎯⎯⎯⎯⎯⎯⎯⎯⎯⎯⎯⎯⎯⎯⎯⎯⎯⎯⎯⎯⎯⎯⎯ Unhandled Error ⎯⎯⎯⎯⎯⎯⎯⎯⎯⎯⎯⎯⎯⎯⎯⎯⎯⎯⎯⎯⎯⎯⎯⎯⎯⎯⎯⎯⎯⎯⎯⎯
Error: requires Node.js >=10.12.0
 ❯ node_modules/@vitest/coverage-v8/dist/provider.js:1803:21
 ❯ ModuleJob.run node:internal/modules/esm/module_job:195:25
 ❯ ModuleLoader.import node:internal/modules/esm/loader:337:24
 ❯ Object.getProvider node_modules/@vitest/coverage-v8/dist/index.js:49:36
 ❯ Vitest.initCoverageProvider node_modules/vitest/dist/vendor/cac.qnW6GNL2.js:11651:29
 ❯ Vitest.start node_modules/vitest/dist/vendor/cac.qnW6GNL2.js:11665:7
 ❯ startVitest node_modules/vitest/dist/vendor/cac.qnW6GNL2.js:18863:5
 ❯ start node_modules/vitest/dist/vendor/cac.qnW6GNL2.js:19645:17
 ❯ CAC.run node_modules/vitest/dist/vendor/cac.qnW6GNL2.js:19626:3
  • Вопрос задан
  • 55 просмотров
Решения вопроса 1
Xeffer
@Xeffer Автор вопроса
frontend dev
Нашёл решение.
Во первых был баг, фикс на который будет в следующей версии.
Во вторых при пустых файлах vue, vitest выдаёт такое поведение.
Ответ написан
Комментировать
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы