maxya-zp
@maxya-zp
Потомственный лесоруб

Как перенести проект Vue.js из PhpStorm на другое рабочее место?

Изначально создавался проект в PhpStorm 2020.1.2 x64 Vue.js vuetifyjs, подключал модули. Выгружал всё на github
Сейчас решил продолжить проект.
Установил PhpStorm 2019.3.4 x64 и не пойму как правильно перенести.
Копируя полностью каталог, горы ошибок.
Устанавливая чистый проект vue и загружая туда все модули, после копируя только каталоги самого кода, также получаю горы ошибок при старте.
На 1м рабочем месте всё работает.
Как правильно перенести?

babel.config.js
module.exports = {
  presets: [
    '@vue/cli-plugin-babel/preset'
  ]
}


composer.json
{
    "require": {
        "cboden/ratchet": "^0.3.6"
    }
}


package.json
{
  "name": "vue-screencasts",
  "version": "0.1.0",
  "private": true,
  "scripts": {
    "serve": "vue-cli-service serve",
    "build": "vue-cli-service build",
    "lint": "vue-cli-service lint"
  },
  "dependencies": {
    "@fortawesome/fontawesome-svg-core": "^1.2.22",
    "@fortawesome/free-solid-svg-icons": "^5.10.2",
    "@fortawesome/vue-fontawesome": "^0.1.7",
    "axios": "^0.21.1",
    "core-js": "^3.1.2",
    "ratchet": "^1.1.0",
    "vue": "^2.6.10",
    "vue-router": "^3.0.6",
    "vue-video-player": "^5.0.2",
    "vuetify": "^2.0.0",
    "vuex": "^3.0.1"
  },
  "devDependencies": {
    "@mdi/font": "^4.4.95",
    "@vue/cli-plugin-babel": "^4.0.0-rc.2",
    "@vue/cli-plugin-eslint": "^4.0.0-rc.2",
    "@vue/cli-plugin-router": "^4.0.0-rc.2",
    "@vue/cli-plugin-vuex": "^4.0.0-rc.2",
    "@vue/cli-service": "^4.0.0-rc.2",
    "babel-eslint": "^10.0.1",
    "eslint": "^5.16.0",
    "eslint-plugin-vue": "^5.0.0",
    "miragejs": "^0.1.41",
    "sass": "^1.19.0",
    "sass-loader": "^7.1.0",
    "vue-cli-plugin-vuetify": "^0.6.3",
    "vue-template-compiler": "^2.6.10",
    "vuetify-loader": "^1.2.2"
  },
  "eslintConfig": {
    "root": true,
    "env": {
      "node": true
    },
    "extends": [
      "plugin:vue/essential"
    ],
    "rules": {},
    "parserOptions": {
      "parser": "babel-eslint"
    }
  },
  "postcss": {
    "plugins": {
      "autoprefixer": {}
    }
  },
  "browserslist": [
    "> 1%",
    "last 2 versions"
  ]
}


vue.config.js
module.exports = {
  transpileDependencies: [
    'vuetify'
  ]
}
  • Вопрос задан
  • 105 просмотров
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы